Bug 510538 - setroubleshoot: SELinux is preventing udev-acl.ck (consolekit_t) "getattr" udev_tbl_t.
setroubleshoot: SELinux is preventing udev-acl.ck (consolekit_t) "getatt...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:022d86ab4b7...
:
: 511029 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-09 13:36 EDT by Joachim Frieben
Modified: 2009-07-15 14:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-15 14:12:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2009-07-09 13:36:10 EDT
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing udev-acl.ck (consolekit_t) "getattr" udev_tbl_t.

Detailed Description:

[SELinux is in permissive mode, the operation would have been denied but was
permitted due to permissive mode.]

SELinux denied access requested by udev-acl.ck. It is not expected that this
access is required by udev-acl.ck and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:consolekit_t:s0-s0:c0.c1023
Target Context                system_u:object_r:udev_tbl_t:s0
Target Objects                /dev/.udev/db/\x2fdevices\x2fpci0000:00\x2f0000:00
                              :02.1\x2fusb1 [ file ]
Source                        udev-acl.ck
Source Path                   /lib/udev/udev-acl
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           udev-143-2.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.20-2.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-0.54.rc2.git2.fc12.x86_64 #1
                              SMP Wed Jul 8 13:38:52 EDT 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Thu 09 Jul 2009 07:29:00 PM CEST
Last Seen                     Thu 09 Jul 2009 07:29:00 PM CEST
Local ID                      b09d7913-74c7-442a-96a4-82a66b962b5b
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1247160540.685:25439): avc:  denied  { getattr } for  pid=1479 comm="udev-acl.ck" path="/dev/.udev/db/\x2fdevices\x2fpci0000:00\x2f0000:00:02.1\x2fusb1" dev=tmpfs ino=3353 scontext=system_u:system_r:consolekit_t:s0-s0:c0.c1023 tcontext=system_u:object_r:udev_tbl_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1247160540.685:25439): arch=c000003e syscall=6 success=yes exit=0 a0=7fff7e258070 a1=7fff7e256bd0 a2=7fff7e256bd0 a3=4 items=0 ppid=797 pid=1479 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="udev-acl.ck" exe="/lib/udev/udev-acl" subj=system_u:system_r:consolekit_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= consolekit_t ==============
allow consolekit_t udev_tbl_t:file getattr;
Comment 1 Daniel Walsh 2009-07-09 17:12:38 EDT
This looks like /lib/udev/udev-acl
 was not labeled correctly, since consolekit should have transitioned when it executed this application

matchpathcon /lib/udev/udev-acl 
/lib/udev/udev-acl	system_u:object_r:udev_exec_t:s0
Comment 2 Michal Nowak 2009-07-13 07:34:49 EDT
*** Bug 511029 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Walsh 2009-07-14 10:45:25 EDT
What does 

ls -lZ /lib/udev/udev-acl 

Say
Comment 4 Michal Nowak 2009-07-14 11:05:49 EDT
-rwxr-xr-x. root root system_u:object_r:bin_t:s0       /lib/udev/udev-acl
Comment 5 Michal Nowak 2009-07-14 11:08:12 EDT
[root@localhost ~]# matchpathcon /lib/udev/udev-acl /lib/udev/udev-acl system_u:object_r:udev_exec_t:s0  
/lib/udev/udev-acl	system_u:object_r:udev_exec_t:s0
/lib/udev/udev-acl	system_u:object_r:udev_exec_t:s0
system_u:object_r:udev_exec_t:s0	<<none>>
Comment 6 Joachim Frieben 2009-07-14 11:32:02 EDT
(In reply to comment #3)
For installed packages
- selinux-policy-targeted-3.6.21-3.fc12 (*)
- udev-145-1.fc12

$ ls -lZ /lib/udev/udev-acl
-rwxr-xr-x. root root system_u:object_r:udev_exec_t:s0 /lib/udev/udev-acl*

I haven't lately seen alerts related to this bug anymore.

(*) filesystem has been autorelabeled after every upgrade of the policy.
Comment 7 Daniel Walsh 2009-07-15 14:12:23 EDT
Michal run restorecon on it and it should be fine.

restorecon -R -v /lib

Note You need to log in before you can comment on or make changes to this bug.