Bug 510605 - endian issues with RAID UUID on ppc
endian issues with RAID UUID on ppc
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mdadm (Show other bugs)
6.0
ppc64 Linux
low Severity medium
: rc
: ---
Assigned To: Doug Ledford
Jan Ščotka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-09 16:58 EDT by Bill Nottingham
Modified: 2014-03-16 23:19 EDT (History)
4 users (show)

See Also:
Fixed In Version: mdadm-3.0-0.devel3.8.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 09:32:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2009-07-09 16:58:52 EDT
Description of problem:

anaconda-written mdadm.conf:

ARRAY /dev/md0 level=raid1 num-devices=2 UUID=3d33116f:1853b1a7:00cf57ef:cb11dcaa

mdadm -E of component device:

/dev/sdb1:
          Magic : a92b4efc
        Version : 0.90.00
           UUID : 6f11333d:a7b15318:ef57cf00:aadc11cb (local to host localhost.localdomain)
  Creation Time : Mon Jul  6 08:04:43 2009
     Raid Level : raid1
  Used Dev Size : 17775552 (16.95 GiB 18.20 GB)
     Array Size : 17775552 (16.95 GiB 18.20 GB)
   Raid Devices : 2
  Total Devices : 2
Preferred Minor : 0

    Update Time : Mon Jul  6 08:28:57 2009
          State : clean
 Active Devices : 2
Working Devices : 2
 Failed Devices : 0
  Spare Devices : 0
       Checksum : efd4c906 - correct
         Events : 6


      Number   Major   Minor   RaidDevice State
this     1       8       17        1      active sync   /dev/sdb1

   0     0       8        3        0      active sync   /dev/sda3
   1     1       8       17        1      active sync   /dev/sdb1

Version-Release number of selected component (if applicable):

RHEL 6 alpha

Steps to Reproduce:
1. Install RAID1.
2.
3. Reboot.
  
Actual results:

fsck fails, as mdadm doesn't activate the device.
Comment 1 RHEL Product and Program Management 2009-07-09 17:18:05 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Bill Nottingham 2009-07-09 19:33:43 EDT
mdadm is broken on ppc, and has been ever since 3.0 landed in February.
Comment 3 Bill Nottingham 2009-07-09 19:35:01 EDT
Fixed in 3.0-0.devel3.8.el6.
Comment 4 releng-rhel@redhat.com 2009-10-30 18:12:44 EDT
Fixed in 'mdadm-3.0-0.devel3.8.el6'. 'mdadm-3.0.2-1.el6' included in compose 'RHEL6.0-20091029.0'.
Moving to ON_QA.
Comment 5 Doug Ledford 2009-11-04 18:39:34 EST
This needs extra special QA love.  I have attempted, for hours on end, to reproduce this bug both with the original packages that Bill was using when he reported this bug and with current packages, and I have been unable to reproduce this under any conditions with either ppc or ppc64 hardware.  I'm am not convinced that this bug represents the true state of things.  However, this bug rendered raid installs on ppc hardware completely DOA on first reboot, so testing that it hasn't come back should be easy.  As a result of the ease of verification, I'm removing the patch that went into 3.0-0.devel3.8 entirely because I can not prove that A) it helps or B) is needed and I don't want it cluttering up the package unnecessarily.
Comment 10 releng-rhel@redhat.com 2010-11-15 09:32:47 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.