Bug 510707 - multipath manual for RHEL5 has no information on online resizing of a LUN
multipath manual for RHEL5 has no information on online resizing of a LUN
Status: CLOSED NOTABUG
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rh-cs-en (Show other bugs)
4
All Linux
low Severity medium
: ---
: ---
Assigned To: Steven J. Levine
Content Services Development
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-10 07:18 EDT by Gerard de Vos
Modified: 2009-09-03 12:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-03 12:47:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerard de Vos 2009-07-10 07:18:58 EDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11

In the RHEL4 multipath manual there is an entry on how to resize a LUN while it is in use. This section was deleted for the RHEL5 version of the manual. Rightfully so because the RHEL4 instructions won't work on kernel 2.6.18/RHEL5. It is possible to resize a LUN while using it though, I wrote down how under "additional information".

Manual identifier:
Bugzilla component: Documentation-cluster
Book identifier: DM_Multipath(EN)-5 (2009-01-06T15:35)


Reproducible: Always




 Use the following procedure to resize an online multipath device.

   1. Resize your physical device.
   2. Find the paths to the LUN:
# multipath -l
   3. Resize your paths. For SCSI devices, writing a 1 to the rescan file for the device causes the SCSI driver to rescan. You can use the following command:
# echo 1 > /sys/block/<device_name>/device/rescan 
   4. Resize your multipath device by running the multipathd resize command:
#  multipathd -k'resize map mpath0'
   5. Resize the filesystem (assuming no LVM or DOS partitions are used)
# resize2fs /dev/mapper/mpath0
Comment 1 Paul Kennedy 2009-07-10 09:50:53 EDT
Reassigned to primary writer, slevine.
Comment 2 Steven J. Levine 2009-08-10 17:26:38 EDT
I sent the following note to Ben Marzinski on July 15, since he's my main technical contact and reviewer here. As soon as I hear back from Ben on this I'll get it into the next revision of the document.

-Steven


Ben:

Could you look at Bug 510707 and verify whether the information there is correct -- and thus whether I should add this procedure to the Multipath document for RHEL 5.4?

Thanks.

-Steven
Comment 3 Ben Marzinski 2009-08-12 16:05:44 EDT
Yes, this should work just fine. You can add it to the Multipath document.
Comment 4 Steven J. Levine 2009-08-14 11:13:46 EDT
I have added this procedure to the 5.4 draft and it will be in the RHEL 5.4 version when it is released.
Comment 5 Gerard de Vos 2009-08-17 07:24:55 EDT
I noticed that on http://www.redhat.com/docs/manuals/enterprise/ there was a document added: "Online Storage Reconfiguration Guide" dated July 15.
This doc does contain the resizing info. Maybe what would be handy is a link in the multipath manual that points to the new doc? Or consolidate the 2 docs?

Cheers,
Gérard
Comment 6 Steven J. Levine 2009-08-17 10:52:35 EDT
(In reply to comment #5)
> I noticed that on http://www.redhat.com/docs/manuals/enterprise/ there was a
> document added: "Online Storage Reconfiguration Guide" dated July 15.
> This doc does contain the resizing info. Maybe what would be handy is a link in
> the multipath manual that points to the new doc? Or consolidate the 2 docs?
> 
> Cheers,
> Gérard  

Gérard,

Thanks for pointing this out. I think I'll leave the procedure supplied here in the multipath manual and add a "for further information" reference to the online storage doc. I'm not sure I can make this an actual link, but I certainly can refer to the document in the manual which should point users to the document.

-Steven
Comment 7 Steven J. Levine 2009-09-03 12:47:16 EDT
With the release of RHEL 5.4, I am closing this bug.

Note You need to log in before you can comment on or make changes to this bug.