Bug 510739 - ipa pwpolicy minlife: Need to define and enforce acceptable data ranges
ipa pwpolicy minlife: Need to define and enforce acceptable data ranges
Status: CLOSED DUPLICATE of bug 510740
Product: freeIPA
Classification: Community
Component: ipa-admintools (Show other bugs)
2.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-10 10:29 EDT by Jenny Galipeau
Modified: 2015-01-04 18:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-23 08:15:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jenny Galipeau 2009-07-10 10:29:46 EDT
Description of problem:

Right now there is no defined or enforced data ranges for minlife.  You can
define the minimum password lifetime with positive integers up to
29999999.  This is unrealistic.

[root@jennyv2 ~]# ipa pwpolicy-mod --minlife=3000000000
ipa: ERROR: non-public: TypeError: value: need a <type 'int'>; got 3000000000L (a <type 'long'>)
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/ipalib/backend.py", line 110, in execute
    result = self.Command[_name](*args, **options)
  File "/usr/lib/python2.4/site-packages/ipalib/plugable.py", line 410, in __call__
    return self['__call__'](*args, **kw)
  File "/usr/lib/python2.4/site-packages/ipalib/frontend.py", line 396, in __call__
    self.validate(**params)
  File "/usr/lib/python2.4/site-packages/ipalib/frontend.py", line 583, in validate
    param.validate(value)
  File "/usr/lib/python2.4/site-packages/ipalib/parameters.py", line 622, in validate
    self._validate_scalar(value)
  File "/usr/lib/python2.4/site-packages/ipalib/parameters.py", line 630, in _validate_scalar
    raise TypeError(
TypeError: value: need a <type 'int'>; got 3000000000L (a <type 'long'>)
ipa: ERROR: an internal error has occurred



Version-Release number of selected component (if applicable):
2.0

How reproducible:
always

Steps to Reproduce:
1. see description example
2.
3.
  
Actual results:
internal error when minlief is defined over 299999999
values up to 299999999 are accepted


Expected results:
Proper error message and no traceback
only values up to realistic minimum password lifetime are accepted 

Additional info:
Comment 1 Pavel Zuna 2009-11-23 08:15:33 EST
Duplicate: https://bugzilla.redhat.com/show_bug.cgi?id=510740

*** This bug has been marked as a duplicate of bug 510740 ***

Note You need to log in before you can comment on or make changes to this bug.