Bug 510754 - During install of external DB seeing "Bad file descriptor" on 2nd attempt to enter DB info
During install of external DB seeing "Bad file descriptor" on 2nd attempt to ...
Status: CLOSED DUPLICATE of bug 466747
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2009-07-10 11:29 EDT by John Matthews
Modified: 2013-04-15 08:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-15 08:05:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2009-07-10 11:29:12 EDT
Description of problem:

During install of external DB seeing "Bad file descriptor" on 2nd attempt to enter DB info.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Use non embedded ISO
2. ./install.pl
3. Enter bad info for the first set of DB info
4. After it can't connect to DB and you get re-prompted for new DB info you will see a "Bad file descriptor".
  
Actual results:
# ./install.pl --answer-file=/root/answers.txt 
* Starting the Red Hat Network Satellite installer.
* Loading answer file: /root/answers.txt.
* Performing pre-install checks.
* Pre-install checks complete.  Beginning installation.
* RHN Registration.
** Registration: System is already registered with RHN.  Not re-registering.
* Installing required packages.
* Applying updates.
* Installing RHN packages.
* Now running setup.
* Loading answer file: /root/answers.txt.
* Setting up Oracle environment.
* Setting up database.
** Database: Setting up database connection.
DB User? jmatthews
DB Password? 
DB SID? rhnsat10
DB hostname? test-db-3
DB port [1521]? 
DB protocol [TCP]? 
Could not connect to the database.  Your connection information may be incorrect.  Error: DBI connect('rhnsat10','jmatthews',...) failed: ORA-01017: invalid username/password; logon denied (DBD ERROR: OCISessionBegin) at /usr/lib/perl5/vendor_perl/5.8.5/Spacewalk/Setup.pm line 1162

DB User? jmatthews
DB Password? stty: standard input: Bad file descriptor
stty: standard input: Bad file descriptor
rhnsat10
stty: standard input: Bad file descriptor


Expected results:
We shouldn't see: "stty: standard input: Bad file descriptor"


Additional info:
Comment 1 Jan Pazdziora 2013-04-15 08:05:34 EDT
The comment 0 does not explicitly state so but I suspect this was an s390x machine and thus marking as dupe of bug 466747.

*** This bug has been marked as a duplicate of bug 466747 ***

Note You need to log in before you can comment on or make changes to this bug.