Bug 510778 - Upgrade doc, rhn-satellite-5-upgrade-scenario-1a.txt is missing option to rhn-satellite-activate, --ignore-version-mismatch
Upgrade doc, rhn-satellite-5-upgrade-scenario-1a.txt is missing option to rhn...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Milan Zazrivec
John Matthews
:
Depends On:
Blocks: 456986
  Show dependency treegraph
 
Reported: 2009-07-10 14:09 EDT by John Matthews
Modified: 2009-08-27 13:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-27 13:38:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2009-07-10 14:09:13 EDT
Description of problem:

Upgrade doc, rhn-satellite-5-upgrade-scenario-1a.txt is missing option to rhn-satellite-activate, --ignore-version-mismatch.  This is already documented in rhn-satellite-5-upgrade-scenario-1b.txt


Version-Release number of selected component (if applicable):
# rpm -q rhn-upgrade
rhn-upgrade-5.3.0.16-1.el4sat


  
Actual results:
12. Activate the RHN Satellite:
   If this is a connected RHN Satellite (i.e., not disconnected):
      o If the new system is not yet registered to RHN, register it
        with the rhn_register or rhnreg_ks commands.
      o Run:
        rhn-satellite-activate --rhn-cert <ABSOLUTE PATH TO *NEW* RHN CERT>
   If disconnected, run:
      rhn-satellite-activate --rhn-cert <ABSOLUTE PATH TO *NEW* RHN CERT> \
                             --disconnected


Expected results:
12. Activate the RHN Satellite:
   If this is a connected RHN Satellite (i.e., not disconnected):
      o If the new system is not yet registered to RHN, register it
        with the rhn_register or rhnreg_ks commands.
      o Run:
        rhn-satellite-activate --ignore-version-mismatch --rhn-cert <ABSOLUTE PATH TO *NEW* RHN CERT>
   If disconnected, run:
      rhn-satellite-activate --ignore-version-mismatch --rhn-cert <ABSOLUTE PATH TO *NEW* RHN CERT> \
                             --disconnected
Comment 1 Milan Zazrivec 2009-07-13 06:28:51 EDT
satellite.git, SATELLITE-5.3: 15feb11c8ae2e1ce23f499174eb0dffdfeeec87a
Comment 2 Milan Zazrivec 2009-07-15 02:47:22 EDT
rhn-upgrade-5.3.0.17-1
Comment 3 John Matthews 2009-07-21 12:17:10 EDT
VERIFIED

rpm -q rhn-upgrade
rhn-upgrade-5.3.0.20-1.el4sat
Comment 4 Miroslav Suchý 2009-08-17 11:03:50 EDT
12. Activate the RHN Satellite:
   If this is a connected RHN Satellite (i.e., not disconnected):
      o If the new system is not yet registered to RHN, register it
        with the rhn_register or rhnreg_ks commands.
      o Run:
        rhn-satellite-activate --rhn-cert <ABSOLUTE PATH TO *NEW* RHN CERT> \
                               --ignore-version-mismatch
   If disconnected, run:
      rhn-satellite-activate --rhn-cert <ABSOLUTE PATH TO *NEW* RHN CERT> \
                             --disconnected --ignore-version-mismatch

verfied in stage
Comment 5 Brandon Perkins 2009-08-27 13:38:30 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1235.html

Note You need to log in before you can comment on or make changes to this bug.