Bug 510830 - Crashed yum while trying to reinstall/install an existing RPM that was force installed w/o deps
Crashed yum while trying to reinstall/install an existing RPM that was force ...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-11 02:45 EDT by Shawn Starr
Modified: 2014-01-21 18:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-03 11:53:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shawn Starr 2009-07-11 02:45:35 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:

Output of craziness: 

1) qt-devel-4.5.2-1.fc11 was force installed before, missing deps:

2) 

[root@segfault ~]# yum reinstall /home/spstarr/Downloads/qt-devel-4.5.2-1.fc11.x86_64.rpm --nogpgcheck
Loaded plugins: refresh-packagekit                                                                    
Setting up Reinstall Process                                                                          
Examining /home/spstarr/Downloads/qt-devel-4.5.2-1.fc11.x86_64.rpm: 1:qt-devel-4.5.2-1.fc11.x86_64    
Resolving Dependencies                                                                                
--> Running transaction check                                                                         
---> Package qt-devel.x86_64 1:4.5.2-1.fc11 set to be erased                                          
---> Package qt-devel.x86_64 1:4.5.2-1.fc11 set to be updated                                         
--> Processing Dependency: libGL-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                    
--> Processing Dependency: libGLU-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                   
--> Processing Dependency: libICE-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                   
--> Processing Dependency: libSM-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                    
--> Processing Dependency: libX11-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                   
--> Processing Dependency: libXcursor-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64               
--> Processing Dependency: libXext-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                  
--> Processing Dependency: libXfixes-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                
--> Processing Dependency: libXft-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                   
--> Processing Dependency: libXi-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                    
--> Processing Dependency: libXinerama-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64              
--> Processing Dependency: libXrandr-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                
y--> Processing Dependency: libXrender-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64              
--> Processing Dependency: libXt-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                    
--> Processing Dependency: libjpeg-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                  
--> Processing Dependency: libpng-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                   
--> Processing Dependency: xorg-x11-proto-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64           
--> Running transaction check                                                                         
---> Package libICE-devel.x86_64 0:1.0.4-7.fc11 set to be updated                                     
---> Package libSM-devel.x86_64 0:1.1.0-4.fc11 set to be updated                                      
---> Package libX11-devel.x86_64 0:1.2.1-2.fc11 set to be updated                                     
--> Processing Dependency: pkgconfig(xcb) >= 1.1.92 for package: libX11-devel-1.2.1-2.fc11.x86_64     
--> Processing Dependency: libxcb-devel for package: libX11-devel-1.2.1-2.fc11.x86_64                 
--> Processing Dependency: libXau-devel for package: libX11-devel-1.2.1-2.fc11.x86_64                 
--> Processing Dependency: libXdmcp-devel for package: libX11-devel-1.2.1-2.fc11.x86_64               
--> Processing Dependency: pkgconfig(xcb) for package: libX11-devel-1.2.1-2.fc11.x86_64               
---> Package libXcursor-devel.x86_64 0:1.1.9-4.fc11 set to be updated                                 
---> Package libXext-devel.x86_64 0:1.0.99.1-2.fc11 set to be updated                                 
---> Package libXfixes-devel.x86_64 0:4.0.3-5.fc11 set to be updated                                  
---> Package libXft-devel.x86_64 0:2.1.13-2.fc11 set to be updated                                    
--> Processing Dependency: fontconfig-devel >= 2.2-1 for package: libXft-devel-2.1.13-2.fc11.x86_64   
--> Processing Dependency: freetype-devel >= 2.1.9-2 for package: libXft-devel-2.1.13-2.fc11.x86_64   
--> Processing Dependency: pkgconfig(freetype2) for package: libXft-devel-2.1.13-2.fc11.x86_64        
--> Processing Dependency: pkgconfig(fontconfig) for package: libXft-devel-2.1.13-2.fc11.x86_64       
---> Package libXi-devel.x86_64 0:1.2.1-1.fc11 set to be updated                                      
---> Package libXinerama-devel.x86_64 0:1.0.3-4.fc11 set to be updated                                
---> Package libXrandr-devel.x86_64 0:1.2.99.4-3.fc11 set to be updated                               
---> Package libXrender-devel.x86_64 0:0.9.4-5.fc11 set to be updated                                 
---> Package libXt-devel.x86_64 0:1.0.5-2.fc11 set to be updated                                      
---> Package libjpeg-devel.x86_64 0:6b-45.fc11 set to be updated                                      
---> Package libpng-devel.x86_64 2:1.2.37-1.fc11 set to be updated                                    
--> Processing Dependency: zlib-devel for package: 2:libpng-devel-1.2.37-1.fc11.x86_64                
---> Package mesa-libGL-devel.x86_64 0:7.6-0.1.fc11 set to be updated                                 
--> Processing Dependency: pkgconfig(libdrm) >= 2.4.3 for package: mesa-libGL-devel-7.6-0.1.fc11.x86_64
--> Processing Dependency: pkgconfig(xdamage) for package: mesa-libGL-devel-7.6-0.1.fc11.x86_64        

--> Processing Dependency: pkgconfig(xxf86vm) for package: mesa-libGL-devel-7.6-0.1.fc11.x86_64
---> Package mesa-libGLU-devel.x86_64 0:7.6-0.1.fc11 set to be updated                         
---> Package xorg-x11-proto-devel.noarch 0:7.4-14.fc11 set to be updated                       
--> Running transaction check                                                                  
---> Package fontconfig-devel.x86_64 0:2.6.99.behdad.20090508-1.fc11 set to be updated         
---> Package freetype-devel.x86_64 0:2.3.9-3.fc11 set to be updated                            
---> Package libXau-devel.x86_64 0:1.0.4-5.fc11 set to be updated                              
---> Package libXdamage-devel.x86_64 0:1.1.1-6.fc11 set to be updated                          
---> Package libXdmcp-devel.x86_64 0:1.0.2-8.fc11 set to be updated                            
---> Package libXxf86vm-devel.x86_64 0:1.0.2-2.fc11 set to be updated                          
---> Package libdrm-devel.x86_64 0:2.4.11-2.fc11 set to be updated                             
--> Processing Dependency: libdrm = 2.4.11-2.fc11 for package: libdrm-devel-2.4.11-2.fc11.x86_64
---> Package libxcb-devel.x86_64 0:1.2-4.fc11 set to be updated                                 
---> Package zlib-devel.x86_64 0:1.2.3-22.fc11 set to be updated                                
--> Running transaction check                                                                   
---> Package libdrm.i586 0:2.4.11-2.fc11 set to be updated                                      
---> Package libdrm.x86_64 0:2.4.11-2.fc11 set to be updated                                    
--> Finished Dependency Resolution                                                              

Dependencies Resolved

==============================================================================================================================================
 Package                         Arch              Version                                     Repository                                Size 
==============================================================================================================================================
Installing:                                                                                                                                   
 qt-devel                        x86_64            1:4.5.2-1.fc11                              /qt-devel-4.5.2-1.fc11.x86_64             24 M 
Removing:                                                                                                                                     
 qt-devel                        x86_64            1:4.5.2-1.fc11                              /qt-devel-4.5.2-1.fc11.x86_64             24 M 
Installing for dependencies:                                                                                                                  
 fontconfig-devel                x86_64            2.6.99.behdad.20090508-1.fc11               fedora                                   225 k 
 freetype-devel                  x86_64            2.3.9-3.fc11                                fedora                                   405 k 
 libICE-devel                    x86_64            1.0.4-7.fc11                                fedora                                    15 k 
 libSM-devel                     x86_64            1.1.0-4.fc11                                fedora                                    11 k 
 libX11-devel                    x86_64            1.2.1-2.fc11                                updates                                  1.1 M 
 libXau-devel                    x86_64            1.0.4-5.fc11                                fedora                                    13 k 
 libXcursor-devel                x86_64            1.1.9-4.fc11                                fedora                                    21 k 
 libXdamage-devel                x86_64            1.1.1-6.fc11                                fedora                                   8.6 k 
 libXdmcp-devel                  x86_64            1.0.2-8.fc11                                fedora                                   9.2 k 
 libXext-devel                   x86_64            1.0.99.1-2.fc11                             fedora                                    64 k 
 libXfixes-devel                 x86_64            4.0.3-5.fc11                                fedora                                    11 k 
 libXft-devel                    x86_64            2.1.13-2.fc11                               fedora                                    19 k 
 libXi-devel                     x86_64            1.2.1-1.fc11                                fedora                                    58 k 
 libXinerama-devel               x86_64            1.0.3-4.fc11                                fedora                                   9.9 k 
 libXrandr-devel                 x86_64            1.2.99.4-3.fc11                             fedora                                    19 k 
 libXrender-devel                x86_64            0.9.4-5.fc11                                fedora                                    11 k 
 libXt-devel                     x86_64            1.0.5-2.fc11                                fedora                                   339 k 
 libXxf86vm-devel                x86_64            1.0.2-2.fc11                                fedora                                    14 k 
 libdrm-devel                    x86_64            2.4.11-2.fc11                               updates-testing                           80 k 
 libjpeg-devel                   x86_64            6b-45.fc11                                  fedora                                   106 k 
 libpng-devel                    x86_64            2:1.2.37-1.fc11                             updates                                  111 k 
 libxcb-devel                    x86_64            1.2-4.fc11                                  updates                                  149 k 
 mesa-libGL-devel                x86_64            7.6-0.1.fc11                                updates                                  485 k 
 mesa-libGLU-devel               x86_64            7.6-0.1.fc11                                updates                                  108 k 
 xorg-x11-proto-devel            noarch            7.4-14.fc11                                 fedora                                   290 k 
 zlib-devel                      x86_64            1.2.3-22.fc11                               fedora                                    44 k 
Updating for dependencies:                                                                                                                    
 libdrm                          i586              2.4.11-2.fc11                               updates-testing                           64 k 
 libdrm                          x86_64            2.4.11-2.fc11                               updates-testing                           65 k 

Transaction Summary
==============================================================================================================================================
Install     27 Package(s)                                                                                                                     
Update       2 Package(s)                                                                                                                     
Remove       1 Package(s)                                                                                                                     

Total size: 28 M
Is this ok [y/N]: Downloading Packages:
Running rpm_check_debug                
Traceback (most recent call last):     
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)                                      
  File "/usr/share/yum-cli/yummain.py", line 261, in main     
    return_code = base.doTransaction()                        
  File "/usr/share/yum-cli/cli.py", line 420, in doTransaction
    msgs = self._run_rpm_check_debug()                        
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 3775, in _run_rpm_check_debug
    self.populateTs(test=1)                                                                  
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 261, in populateTs           
    self.ts.addErase(txmbr.po.idx)                                                           
  File "/usr/lib/python2.6/site-packages/yum/packages.py", line 1126, in __getattr__         
    return self.hdr[thing]                                                                   
KeyError: 'unknown header tag'                                                               

Crashes

Workaround was to rpm -e qt-devel then do:

[root@segfault ~]# yum install /home/spstarr/Downloads/qt-devel-4.5.2-1.fc11.x86_64.rpm --nogpgcheck
Loaded plugins: refresh-packagekit                                                                  
Setting up Install Process                                                                          
Examining /home/spstarr/Downloads/qt-devel-4.5.2-1.fc11.x86_64.rpm: 1:qt-devel-4.5.2-1.fc11.x86_64  
Marking /home/spstarr/Downloads/qt-devel-4.5.2-1.fc11.x86_64.rpm to be installed                    
Resolving Dependencies                                                                              
--> Running transaction check                                                                       
---> Package qt-devel.x86_64 1:4.5.2-1.fc11 set to be updated                                       
--> Processing Dependency: libGL-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                  
--> Processing Dependency: libGLU-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                 
--> Processing Dependency: libICE-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                 
--> Processing Dependency: libSM-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                  
--> Processing Dependency: libX11-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                 
--> Processing Dependency: libXcursor-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64             
--> Processing Dependency: libXext-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                
--> Processing Dependency: libXfixes-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64              
--> Processing Dependency: libXft-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                 
--> Processing Dependency: libXi-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                  
--> Processing Dependency: libXinerama-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64            
--> Processing Dependency: libXrandr-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64              
--> Processing Dependency: libXrender-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64             
--> Processing Dependency: libXt-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                  
--> Processing Dependency: libjpeg-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                
--> Processing Dependency: libpng-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64                 
--> Processing Dependency: xorg-x11-proto-devel for package: 1:qt-devel-4.5.2-1.fc11.x86_64         
--> Running transaction check                                                                       
---> Package libICE-devel.x86_64 0:1.0.4-7.fc11 set to be updated                                   
---> Package libSM-devel.x86_64 0:1.1.0-4.fc11 set to be updated                                    
---> Package libX11-devel.x86_64 0:1.2.1-2.fc11 set to be updated                                   
--> Processing Dependency: pkgconfig(xcb) >= 1.1.92 for package: libX11-devel-1.2.1-2.fc11.x86_64   
--> Processing Dependency: libxcb-devel for package: libX11-devel-1.2.1-2.fc11.x86_64               
--> Processing Dependency: libXau-devel for package: libX11-devel-1.2.1-2.fc11.x86_64               
--> Processing Dependency: libXdmcp-devel for package: libX11-devel-1.2.1-2.fc11.x86_64             
--> Processing Dependency: pkgconfig(xcb) for package: libX11-devel-1.2.1-2.fc11.x86_64             
---> Package libXcursor-devel.x86_64 0:1.1.9-4.fc11 set to be updated                               
---> Package libXext-devel.x86_64 0:1.0.99.1-2.fc11 set to be updated                               
---> Package libXfixes-devel.x86_64 0:4.0.3-5.fc11 set to be updated                                
---> Package libXft-devel.x86_64 0:2.1.13-2.fc11 set to be updated                                  
--> Processing Dependency: fontconfig-devel >= 2.2-1 for package: libXft-devel-2.1.13-2.fc11.x86_64 
--> Processing Dependency: freetype-devel >= 2.1.9-2 for package: libXft-devel-2.1.13-2.fc11.x86_64 
--> Processing Dependency: pkgconfig(freetype2) for package: libXft-devel-2.1.13-2.fc11.x86_64      
--> Processing Dependency: pkgconfig(fontconfig) for package: libXft-devel-2.1.13-2.fc11.x86_64     
---> Package libXi-devel.x86_64 0:1.2.1-1.fc11 set to be updated                                    
---> Package libXinerama-devel.x86_64 0:1.0.3-4.fc11 set to be updated                              
---> Package libXrandr-devel.x86_64 0:1.2.99.4-3.fc11 set to be updated                             
---> Package libXrender-devel.x86_64 0:0.9.4-5.fc11 set to be updated                               
---> Package libXt-devel.x86_64 0:1.0.5-2.fc11 set to be updated                                    
---> Package libjpeg-devel.x86_64 0:6b-45.fc11 set to be updated                                    
---> Package libpng-devel.x86_64 2:1.2.37-1.fc11 set to be updated                                  
--> Processing Dependency: zlib-devel for package: 2:libpng-devel-1.2.37-1.fc11.x86_64              
---> Package mesa-libGL-devel.x86_64 0:7.6-0.1.fc11 set to be updated                               
--> Processing Dependency: pkgconfig(libdrm) >= 2.4.3 for package: mesa-libGL-devel-7.6-0.1.fc11.x86_64
--> Processing Dependency: pkgconfig(xdamage) for package: mesa-libGL-devel-7.6-0.1.fc11.x86_64        
--> Processing Dependency: pkgconfig(xxf86vm) for package: mesa-libGL-devel-7.6-0.1.fc11.x86_64        
---> Package mesa-libGLU-devel.x86_64 0:7.6-0.1.fc11 set to be updated                                 
---> Package xorg-x11-proto-devel.noarch 0:7.4-14.fc11 set to be updated                               
--> Running transaction check                                                                          
---> Package fontconfig-devel.x86_64 0:2.6.99.behdad.20090508-1.fc11 set to be updated                 
---> Package freetype-devel.x86_64 0:2.3.9-3.fc11 set to be updated                                    
---> Package libXau-devel.x86_64 0:1.0.4-5.fc11 set to be updated                                      
---> Package libXdamage-devel.x86_64 0:1.1.1-6.fc11 set to be updated                                  
---> Package libXdmcp-devel.x86_64 0:1.0.2-8.fc11 set to be updated                                    
---> Package libXxf86vm-devel.x86_64 0:1.0.2-2.fc11 set to be updated                                  
---> Package libdrm-devel.x86_64 0:2.4.11-2.fc11 set to be updated                                     
--> Processing Dependency: libdrm = 2.4.11-2.fc11 for package: libdrm-devel-2.4.11-2.fc11.x86_64       
---> Package libxcb-devel.x86_64 0:1.2-4.fc11 set to be updated                                        
---> Package zlib-devel.x86_64 0:1.2.3-22.fc11 set to be updated                                       
--> Running transaction check                                                                          
---> Package libdrm.i586 0:2.4.11-2.fc11 set to be updated                                             
---> Package libdrm.x86_64 0:2.4.11-2.fc11 set to be updated                                           
y                                                                                                      
--> Finished Dependency Resolution                                                                     

Dependencies Resolved

==============================================================================================================================================
 Package                         Arch              Version                                     Repository                                Size 
==============================================================================================================================================
Installing:                                                                                                                                   
 qt-devel                        x86_64            1:4.5.2-1.fc11                              /qt-devel-4.5.2-1.fc11.x86_64             24 M 
Installing for dependencies:                                                                                                                  
 fontconfig-devel                x86_64            2.6.99.behdad.20090508-1.fc11               fedora                                   225 k 
 freetype-devel                  x86_64            2.3.9-3.fc11                                fedora                                   405 k 
 libICE-devel                    x86_64            1.0.4-7.fc11                                fedora                                    15 k 
 libSM-devel                     x86_64            1.1.0-4.fc11                                fedora                                    11 k 
 libX11-devel                    x86_64            1.2.1-2.fc11                                updates                                  1.1 M 
 libXau-devel                    x86_64            1.0.4-5.fc11                                fedora                                    13 k 
 libXcursor-devel                x86_64            1.1.9-4.fc11                                fedora                                    21 k 
 libXdamage-devel                x86_64            1.1.1-6.fc11                                fedora                                   8.6 k 
 libXdmcp-devel                  x86_64            1.0.2-8.fc11                                fedora                                   9.2 k 
 libXext-devel                   x86_64            1.0.99.1-2.fc11                             fedora                                    64 k 
 libXfixes-devel                 x86_64            4.0.3-5.fc11                                fedora                                    11 k 
 libXft-devel                    x86_64            2.1.13-2.fc11                               fedora                                    19 k 
 libXi-devel                     x86_64            1.2.1-1.fc11                                fedora                                    58 k 
 libXinerama-devel               x86_64            1.0.3-4.fc11                                fedora                                   9.9 k 
 libXrandr-devel                 x86_64            1.2.99.4-3.fc11                             fedora                                    19 k 
 libXrender-devel                x86_64            0.9.4-5.fc11                                fedora                                    11 k 
 libXt-devel                     x86_64            1.0.5-2.fc11                                fedora                                   339 k 
 libXxf86vm-devel                x86_64            1.0.2-2.fc11                                fedora                                    14 k 
 libdrm-devel                    x86_64            2.4.11-2.fc11                               updates-testing                           80 k 
 libjpeg-devel                   x86_64            6b-45.fc11                                  fedora                                   106 k 
 libpng-devel                    x86_64            2:1.2.37-1.fc11                             updates                                  111 k 
 libxcb-devel                    x86_64            1.2-4.fc11                                  updates                                  149 k 
 mesa-libGL-devel                x86_64            7.6-0.1.fc11                                updates                                  485 k 
 mesa-libGLU-devel               x86_64            7.6-0.1.fc11                                updates                                  108 k 
 xorg-x11-proto-devel            noarch            7.4-14.fc11                                 fedora                                   290 k 
 zlib-devel                      x86_64            1.2.3-22.fc11                               fedora                                    44 k 
Updating for dependencies:                                                                                                                    
 libdrm                          i586              2.4.11-2.fc11                               updates-testing                           64 k 
 libdrm                          x86_64            2.4.11-2.fc11                               updates-testing                           65 k 

Transaction Summary
==============================================================================================================================================
Install     27 Package(s)                                                                                                                     
Update       2 Package(s)                                                                                                                     
Remove       0 Package(s)                                                                                                                     

Total size: 28 M
Is this ok [y/N]: Downloading Packages:
Running rpm_check_debug                
Running Transaction Test               
Finished Transaction Test              
Transaction Test Succeeded             
Running Transaction                    
  Installing     : xorg-x11-proto-devel-7.4-14.fc11.noarch                                                                               1/31 
  Updating       : libdrm-2.4.11-2.fc11.x86_64                                                                                           2/31 
  Installing     : libXau-devel-1.0.4-5.fc11.x86_64                                                                                      3/31 
  Installing     : libICE-devel-1.0.4-7.fc11.x86_64                                                                                      4/31 
  Installing     : libSM-devel-1.1.0-4.fc11.x86_64                                                                                       5/31 
  Installing     : zlib-devel-1.2.3-22.fc11.x86_64                                                                                       6/31 
  Installing     : freetype-devel-2.3.9-3.fc11.x86_64                                                                                    7/31 
  Installing     : fontconfig-devel-2.6.99.behdad.20090508-1.fc11.x86_64                                                                 8/31 
  Installing     : 2:libpng-devel-1.2.37-1.fc11.x86_64                                                                                   9/31 
  Installing     : libxcb-devel-1.2-4.fc11.x86_64                                                                                       10/31 
  Installing     : libXdmcp-devel-1.0.2-8.fc11.x86_64                                                                                   11/31 
  Installing     : libX11-devel-1.2.1-2.fc11.x86_64                                                                                     12/31 
  Installing     : libXext-devel-1.0.99.1-2.fc11.x86_64                                                                                 13/31 
  Installing     : libXfixes-devel-4.0.3-5.fc11.x86_64                                                                                  14/31 
  Installing     : libXrender-devel-0.9.4-5.fc11.x86_64                                                                                 15/31 
  Installing     : libXt-devel-1.0.5-2.fc11.x86_64                                                                                      16/31 
  Installing     : libXrandr-devel-1.2.99.4-3.fc11.x86_64                                                                               17/31 
  Installing     : libXcursor-devel-1.1.9-4.fc11.x86_64                                                                                 18/31 
  Installing     : libXft-devel-2.1.13-2.fc11.x86_64                                                                                    19/31 
  Installing     : libXdamage-devel-1.1.1-6.fc11.x86_64                                                                                 20/31 
  Installing     : libXxf86vm-devel-1.0.2-2.fc11.x86_64                                                                                 21/31 
  Installing     : libXi-devel-1.2.1-1.fc11.x86_64                                                                                      22/31 
  Installing     : libXinerama-devel-1.0.3-4.fc11.x86_64                                                                                23/31 
  Installing     : libjpeg-devel-6b-45.fc11.x86_64                                                                                      24/31 
  Updating       : libdrm-2.4.11-2.fc11.i586                                                                                            25/31 
  Installing     : libdrm-devel-2.4.11-2.fc11.x86_64                                                                                    26/31 
  Installing     : mesa-libGL-devel-7.6-0.1.fc11.x86_64                                                                                 27/31 
  Installing     : mesa-libGLU-devel-7.6-0.1.fc11.x86_64                                                                                28/31 
  Installing     : 1:qt-devel-4.5.2-1.fc11.x86_64                                                                                       29/31 
  Cleanup        : libdrm-2.4.6-7.fc11                                                                                                  30/31 
  Cleanup        : libdrm-2.4.6-7.fc11                                                                                                  31/31 

Installed:
  qt-devel.x86_64 1:4.5.2-1.fc11                                                                                                              

Dependency Installed:
  fontconfig-devel.x86_64 0:2.6.99.behdad.20090508-1.fc11  freetype-devel.x86_64 0:2.3.9-3.fc11     libICE-devel.x86_64 0:1.0.4-7.fc11       
  libSM-devel.x86_64 0:1.1.0-4.fc11                        libX11-devel.x86_64 0:1.2.1-2.fc11       libXau-devel.x86_64 0:1.0.4-5.fc11       
  libXcursor-devel.x86_64 0:1.1.9-4.fc11                   libXdamage-devel.x86_64 0:1.1.1-6.fc11   libXdmcp-devel.x86_64 0:1.0.2-8.fc11     
  libXext-devel.x86_64 0:1.0.99.1-2.fc11                   libXfixes-devel.x86_64 0:4.0.3-5.fc11    libXft-devel.x86_64 0:2.1.13-2.fc11      
  libXi-devel.x86_64 0:1.2.1-1.fc11                        libXinerama-devel.x86_64 0:1.0.3-4.fc11  libXrandr-devel.x86_64 0:1.2.99.4-3.fc11 
  libXrender-devel.x86_64 0:0.9.4-5.fc11                   libXt-devel.x86_64 0:1.0.5-2.fc11        libXxf86vm-devel.x86_64 0:1.0.2-2.fc11   
  libdrm-devel.x86_64 0:2.4.11-2.fc11                      libjpeg-devel.x86_64 0:6b-45.fc11        libpng-devel.x86_64 2:1.2.37-1.fc11      
  libxcb-devel.x86_64 0:1.2-4.fc11                         mesa-libGL-devel.x86_64 0:7.6-0.1.fc11   mesa-libGLU-devel.x86_64 0:7.6-0.1.fc11  
  xorg-x11-proto-devel.noarch 0:7.4-14.fc11                zlib-devel.x86_64 0:1.2.3-22.fc11                                                 

Dependency Updated:
  libdrm.i586 0:2.4.11-2.fc11                                          libdrm.x86_64 0:2.4.11-2.fc11                                         

Complete!
Comment 1 James Antill 2009-07-13 10:29:11 EDT
The reinstall case is known, and fixed upstream ... it happens when you use a local package. So you can make it work by either using/creating a repo. with your qt-devel package in it, and just specifying the name, or updating to the yum in rawhide.

The install case looks like it worked fine, no?

Note You need to log in before you can comment on or make changes to this bug.