Bug 510851 - Page 16: 3.2.3. /proc/cmdline - shouldn't be "root filesystem" instead of "kernel"?
Page 16: 3.2.3. /proc/cmdline - shouldn't be "root filesystem" instead of "ke...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Deployment_Guide (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Douglas Silas
Joshua Wulf
: Documentation
: 507512 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-11 12:11 EDT by Tomasz Chrzczonowicz
Modified: 2014-10-19 18:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-25 17:17:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomasz Chrzczonowicz 2009-07-11 12:11:24 EDT
"ro root=/dev/VolGroup00/LogVol00 rhgb quiet 3

This tells us that the kernel is mounted read-only (signified by (ro)), located on the first logical
volume (LogVol00) of the first volume group (/dev/VolGroup00). LogVol00 is the equivalent of
a disk partition in a non-LVM system (Logical Volume Management), just as /dev/VolGroup00 is
similar in concept to /dev/hda1, but much more extensible."

Isn't it the root filesystem that is mounted here? IIRC kernel location is specified by options "root (<drive>,<partition>)" and "kernel <location>" in grub.conf
Comment 1 Douglas Silas 2009-09-02 16:52:56 EDT
I believe you are right, and that the paragraph should more accurately read:

"ro root=/dev/VolGroup00/LogVol00 rhgb quiet 3

This tells us that the kernel is mounted read-only (signified by (ro)), *that the root file system is* located on the first logical volume (LogVol00) of the first volume group (/dev/VolGroup00). LogVol00 is the equivalent of a disk partition in a non-LVM system (Logical Volume Management), just as /dev/VolGroup00 is similar in concept to /dev/hda1, but much more extensible."

Also, shouldn't a volume group be logically compared with /dev/hda instead of /dev/hda1?

Asking others for input.
Comment 2 Douglas Silas 2009-09-02 16:53:23 EDT
Setting to ASSIGNED, not MODIFIED.
Comment 3 Tomasz Chrzczonowicz 2009-09-03 15:55:44 EDT
>Also, shouldn't a volume group be logically compared with /dev/hda instead of
>/dev/hda1?

Yes, what you proposed would make more sense.
Comment 4 Douglas Silas 2009-09-10 19:12:59 EDT
just to be clear, the text I am proposing (slightly changed from above) is:

"ro root=/dev/VolGroup00/LogVol00 rhgb quiet 3

This tells us that the kernel is mounted read-only (signified by (ro)), that
the root file system is located on the first logical volume (LogVol00) of the
first volume group (/dev/VolGroup00). LogVol00 is the equivalent of a disk
partition in a non-LVM system (Logical Volume Management), just as
/dev/VolGroup00 is similar in concept to a hard drive, but more extensible."

This text is in the Deployment Guide section on /proc/cmdline:

http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.4/html/Deployment_Guide/s2-proc-cmdline.html
Comment 5 Douglas Silas 2009-09-10 19:15:49 EDT
*** Bug 507512 has been marked as a duplicate of this bug. ***
Comment 7 Ian.Goodacre 2009-09-10 23:51:54 EDT
I think it is the root file system that is mounted read only, not the kernel.
Comment 8 Douglas Silas 2009-09-13 16:31:23 EDT
Ian, you are correct about this. I have rewritten most of the /proc/cmdline entry as follows (-r 22013 in 5.4):

[SNIP]
3.2.3. /proc/cmdline
This file shows the parameters passed to the kernel at the time it is started. A sample /proc/cmdline file looks like the following:

ro root=/dev/VolGroup00/LogVol00 rhgb quiet 3

This output tells us the following:

ro
    The root device is mounted read-only at boot time. The presence of ro on the kernel boot line overrides any instances of rw. 

root=/dev/VolGroup00/LogVol00
    This tells us on which disk device or, in this case, on which logical volume, the root filesystem image is located. With our sample /proc/cmdline output, the root filesystem image is located on the first logical volume (LogVol00) of the first LVM volume group (VolGroup00). On a system not using Logical Volume Management, the root file system might be located on /dev/sda1 or /dev/sda2, meaning on either the first or second partition of the first SCSI or SATA disk drive, depending on whether we have a separate (preceding) boot or swap partition on that drive.
    For more information on LVM used in Red Hat Enterprise Linux, refer to http://www.tldp.org/HOWTO/LVM-HOWTO/index.html.

rhgb
    A short lowercase acronym that stands for Red Hat Graphical Boot, providing "rhgb" on the kernel command line signals that graphical booting is supported, assuming that /etc/inittab shows that the default runlevel is set to 5 with a line like this:

    id:5:initdefault:

quiet
    Indicates that all verbose kernel messages except those which are extremely serious should be suppressed at boot time. 
[/SNIP]
Comment 10 Andrew Ross 2009-11-25 17:17:51 EST
Verified.

Closing.

Note You need to log in before you can comment on or make changes to this bug.