Bug 511013 - Fix locking method in several network drivers to use irq-safe locking and avoid crash
Fix locking method in several network drivers to use irq-safe locking and avo...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-13 04:57 EDT by g.trentalancia
Modified: 2009-08-09 15:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.6.27.29-170.2.78
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-09 15:09:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kernel patch to fix locking method in some network interface drivers (11.94 KB, patch)
2009-07-13 04:57 EDT, g.trentalancia
no flags Details | Diff

  None (edit)
Description g.trentalancia 2009-07-13 04:57:39 EDT
Created attachment 351449 [details]
Kernel patch to fix locking method in some network interface drivers

Description of problem:
The mkiss driver crashes because of bottom-half locking method.

Version-Release number of selected component (if applicable):
2.6.27.25-170.2.72.fc10 (actually all kernel versions up to and including 2.6.30.1 are affected)

How reproducible:
Use the mkiss serial driver (for example with a FTDI USB to serial converter)

Steps to Reproduce:
1. load the mkiss kernel module
2. attach a kiss interface (kissattach)
3. change the kiss interface parameters (kissparms) or try sending packets trough it
  
Actual results:
The driver crashes and kernel oops are generated (see, for example, http://www.kerneloops.org/submitresult.php?number=529746).

Expected results:
The driver should not crash.

Additional info:
The attached patch has been provided by the module maintainer and it fixes the problem.
Comment 1 g.trentalancia 2009-08-09 15:09:34 EDT
Fixed with kernel version 2.6.27.29-170.2.78.

Note You need to log in before you can comment on or make changes to this bug.