Bug 511021 - setuptools does not understand svn format for Subversion 1.6
setuptools does not understand svn format for Subversion 1.6
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-setuptools (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Konstantin Ryabitsev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-13 05:50 EDT by Felix Schwarz
Modified: 2009-08-04 20:29 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.6c9-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-04 20:29:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Schwarz 2009-07-13 05:50:03 EDT
python-setuptools-0.6c9-3.fc11.noarch does not work with the internal format of Subversion 1.6. There is a patch for setuptools (http://bugs.python.org/setuptools/issue64) which solves the problem. Despite the discussions if the setuptools approach is broken by design (I think it is) we should still add the patch to make setuptools work properly with Subversion 1.6.
Comment 1 Paul Howarth 2009-07-14 09:21:24 EDT
(In reply to comment #0)
> we should still add the patch to make setuptools work properly with Subversion
> 1.6.  

Seconded, at least for F-11 and Rawhide. A local build with http://bugs.python.org/setuptools/file55/svn_versioning_4.patch has fixed the issue for me.
Comment 2 Fedora Update System 2009-07-14 10:28:30 EDT
python-setuptools-0.6c9-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/python-setuptools-0.6c9-4.fc11
Comment 3 Fedora Update System 2009-07-19 06:06:19 EDT
python-setuptools-0.6c9-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-setuptools'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7698
Comment 4 Fedora Update System 2009-08-04 20:29:39 EDT
python-setuptools-0.6c9-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.