Bug 511033 - Yum update would not recognize newest version of 3 installed programs
Yum update would not recognize newest version of 3 installed programs
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.4
x86_64 Linux
low Severity medium
: beta
: ---
Assigned To: packaging-team-maint
BaseOS QE Security Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-13 07:47 EDT by Markus Isler, Ph.D.
Modified: 2014-01-21 01:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-12 16:40:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of yum update error output (35.14 KB, image/png)
2009-07-13 07:47 EDT, Markus Isler, Ph.D.
no flags Details

  None (edit)
Description Markus Isler, Ph.D. 2009-07-13 07:47:58 EDT
Created attachment 351461 [details]
screenshot of yum update error output

Description of problem: yum update eternal cycle problem 


Version-Release number of selected component (if applicable):3.2.23-0


How reproducible: always


Steps to Reproduce:
1. updated to redhat-5.4-beta
2. yum update
3. openib-mstflint-1.2-6.el5_1.1 replacing mstflint-1.4-1.el5, openib-perftest-1.2-6.el5_1.1 replacing perftest-1.2-14.el5, and tvflash-0.9.0-2.el5 replacing openib-tvflash-0.9.2-8.el5_2, AND VICE-VERSA
  
Actual results: independent of which of the above versions is installed, it would
always replace each other when running a simple "yum update"

Expected results: that "yum" would recognize the apparently newer version number


Additional info: uname -r : 2.6.18-155.el5 x86_64, cat /etc/*release: RHE Linux Client release 5.4 Beta (Tikanga); also, rhn-profile-sync would not update my system-profile in a way that the automatic eMailer for updates (RHN Errata Alert) would register it (i.e. recent kernel update already installed).
Comment 1 James Antill 2009-07-13 10:48:47 EDT
openib-mstflint-1.2-6.el5_1.1 replacing mstflint-1.4-1.el5
[...]
AND VICE-VERSA

Expected results: that "yum" would recognize the apparently newer version
number

...no, that's not how it works, openib-mstflint and mstflint are different packages so there is no valid way to compare version numbers.
 I assume they are obsoleting each other?

 IIRC this isn't a regression, this happens with 3.2.18-19 (and also with 3.2.8, or it dies in weird ways) ... can you confirm (yum downgrade yum).

 The obvious way to fix this is to break the obsoletes loop, there are a couple of options the most obviuos/recommended is using versioned obsoletes only (Ie. Obsoletes: foo < 1.2.3).

Note You need to log in before you can comment on or make changes to this bug.