Bug 511097 - xpad replicates on desktop at startup even though turned off
xpad replicates on desktop at startup even though turned off
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xpad (Show other bugs)
11
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Simon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-13 12:20 EDT by stan
Modified: 2009-10-22 02:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-22 02:16:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Shows that xpad is not selected in startup setting (82.64 KB, image/png)
2009-07-13 12:20 EDT, stan
no flags Details
Shows proliferation of xpad instances on desktop (49.77 KB, image/png)
2009-07-13 12:21 EDT, stan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 398982 None None None Never

  None (edit)
Description stan 2009-07-13 12:20:37 EDT
Created attachment 351490 [details]
Shows that xpad is not selected in startup setting

Description of problem:  When logging into gnome on F11 x86_64, even though xpad is turned off in the startup menu, it still starts and generates 25 instances on the desktop.


Version-Release number of selected component (if applicable):  
xpad-4.0-2.fc11.x86_64


How reproducible:  Every time I log in.


Steps to Reproduce:
1.  Initially, xpad was turned on by default, only a single instance generated.
2.  Turned off xpad in startup menu.
3.  Xpad still started at login, now with many instances (25)
  
Actual results:
Xpad is started with many instances.

Expected results:
Xpad doesn't start.


Additional info:  See attached png of setting and proliferation.
Comment 1 stan 2009-07-13 12:21:36 EDT
Created attachment 351491 [details]
Shows proliferation of xpad instances on desktop
Comment 2 Stefan Posdzich 2009-07-13 16:14:50 EDT
Hi!

I cant reproduce the bug on F11 x86. Its working as expected.
Even if i disable the automatic startup.

I have reported the bug to upstream. I will try to get the bug fixed.

Thank you for the report!
Comment 3 stan 2009-07-13 19:19:35 EDT
Thank you for the action.  This is mostly an annoyance.  I'll keep trying things to see if I can find a way to fix it.

The fact that you can't reproduce it makes it seem like it is something about my system causing it.  And it is difficult to give good instructions because I didn't really pay attention to it until it started putting lots of them on the desktop.  At first it was just one.
Comment 4 stan 2009-07-17 20:45:32 EDT
More information.  

In System->Preferences->startup applications, I had selected 
terminal in each window on start
When I removed that selection and instead selected 
automatically remember running applications when logging out
the problem disappeared.

So a workaround.
Comment 5 Christoph Wickert 2009-10-16 01:50:27 EDT
(In reply to comment #4)
> When I removed that selection and instead selected 
> automatically remember running applications when logging out
> the problem disappeared.
> 
> So a workaround.  

I think this is not only a workaround but also the cause of the problems. Have you turned on automatic session saving on logout or did you save the session before?
Comment 6 Simon 2009-10-19 01:48:56 EDT
I've tried it with session saving, can't reproduce it.
Perhaps it was a mix of session saving and maloperation of the user that causes to this error.
I will try to reproduce it again, after you give me more info. Do you remember, what do you have done?
Seems to me, this is not a bug!
Comment 7 stan 2009-10-19 02:13:46 EDT
Actually, I have moved to Fedora 12/Rawhide for over a month now.  This problem is not present with F12 as far as I can tell.  And after I implemented the workaround described above, I didn't have the problem anymore on F11.  So it seems like this bugzilla can be closed as notabug.

Thanks for your efforts.

Note You need to log in before you can comment on or make changes to this bug.