Bug 511100 - Provisioning a system fails after certain paths of upgrade: Could not find Cobbler error
Provisioning a system fails after certain paths of upgrade: Could not find Co...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
530
All Linux
urgent Severity high
: ---
: ---
Assigned To: Partha Aji
Sayli Karmarkar
:
: 514214 (view as bug list)
Depends On:
Blocks: 456986 457075
  Show dependency treegraph
 
Reported: 2009-07-13 12:34 EDT by Sayli Karmarkar
Modified: 2009-08-27 13:38 EDT (History)
7 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-27 13:38:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhn_check -vvvv (21.69 KB, text/plain)
2009-07-13 12:39 EDT, Sayli Karmarkar
no flags Details
rhn_check -vvv ks errors (6.34 KB, text/plain)
2009-07-13 12:43 EDT, John Matthews
no flags Details
rhncheck -vvv ks errors after upgrade (3.04 KB, text/plain)
2009-07-13 12:56 EDT, Preethi Thomas
no flags Details

  None (edit)
Description Sayli Karmarkar 2009-07-13 12:34:35 EDT
Description of problem:

I did an upgrade from Sat 3.7.1 7 RHEL2.1 i386 EO  -> Sat 5.3.0 RHEL5 x86_64 EO. 

As this was os upgrade plus arch change (scenario 1a), I had to change hostname of new server to old server. Not sure whether that is causing the problem, but here is what I am seeing when I schedule provisioning of system through webui and run rhn_check on client: 


Traceback attached.
Comment 1 Sayli Karmarkar 2009-07-13 12:39:35 EDT
Created attachment 351493 [details]
rhn_check -vvvv
Comment 2 John Matthews 2009-07-13 12:43:52 EDT
Created attachment 351494 [details]
rhn_check -vvv ks errors
Comment 3 Clifford Perry 2009-07-13 12:46:28 EDT
Sayli - changing a hostname is NOT supported on production Satellites. 

You keep the same hostname over upgrades. Backup all needed data to somewhere off server, reinstall OS on same hostname, restore/upgrade.

Please reproduce on a system where hostname was preserved. 

Cliff
Comment 4 Clifford Perry 2009-07-13 12:49:11 EDT
Also - check rhn.conf for cobbler setting - it maybe currently set to 'localhost' this is incorrect. Set the Satellite server hostname within rhn.conf. 

Further - review your /etc/hosts file to make sure localhost and hostname are correctly configured. 

127.0.0.1 localhost
my-ip     servername 


Cliff
Comment 5 Clifford Perry 2009-07-13 12:50:39 EDT
D: do_call kickstart.initiate ('localhost', 'spacewalk-koan', ' ksdevice=eth0 console=ttyS0,115200 ', '', 'sun-v20z-01.rhts.bos.redhat.com:1', [])
Preserve files! : []
- looking for Cobbler at http://localhost/cobbler_api
Traceback (most recent call last):


We need to confirm why 'localhost' - if it is due to normal upgrade and/or hostname/hosts issue or cos you renamed the Satellite's hostname during upgrade. 

Cliff
Comment 6 John Matthews 2009-07-13 12:51:48 EDT
I am running into a similar problem sayli is seeing namely:

D: do_call kickstart.initiate ('localhost', 'spacewalk-koan', ' ksdevice=eth0 console=ttyS0,115200 ', '', 'sun-v20z-01.rhts.bos.redhat.com:1', [])
Preserve files! : []
- looking for Cobbler at http://localhost/cobbler_api

My Scenario is:

Sat 4.2.2 with External DB installed on RHEL4 i386.
Upgrade to Sat 5.3.0 RHEL4 s390x with External DB


My upgrade steps were (following scenario 1a)
1) Install sat 4.2.2 on external DB of rhnsat/rhnsat@rhnsat 
2) Install sat 530 on rhel4 s390x with a temporary external db jwmrhnsat10/rhnsat10/rhnsat10
3) Upgrade sat422 external db rhnsat to oracle 10g
4) Upgrade schema of sat422 on oracle 10g to sat530 schema, call this new db instance "jwmrhnsat"
5) Point my 530 install to new db instannce of "jwmrhnsat" which was the 4.2.2 sat with upgraded schema.


I did change hostnames, I went from hostname rlx-0-24.rhndev.redhat.com to rhndev1.z900.redhat.com.
Comment 7 Preethi Thomas 2009-07-13 12:55:18 EDT
I reproduced this as well
scenario
rhel4 5.11 to rhel4 5.3 no os upgrade. so no hostname change.
used the a profile that was created pre upgrade. will retest with a new profile.
Comment 8 Preethi Thomas 2009-07-13 12:56:55 EDT
Created attachment 351495 [details]
rhncheck -vvv ks errors after upgrade
Comment 9 Clifford Perry 2009-07-13 13:17:23 EDT
OK - during install we write:

 cobbler.host = rlx-1-18.rhndev.redhat.com

into the /etc/rhn/rhn.conf file - during the upgrade process though we will run various scripts to deploy/activate osad/push, Monitoring and misc other things, these scripts write/update config files within the /etc/sysconfig/rhn-satellite-prep/ and re-deploy. Because of this the rhn.conf file entry is lost (well backed up):


[root@rlx-3-08 rhn-satellite-prep]# grep -ir cobbler /etc/sysconfig/rhn/backup-2009-07-1*
/etc/sysconfig/rhn/backup-2009-07-13-12:48/etc/rhn/rhn.conf:cobbler.host = rlx-3-08.rhndev.redhat.com
[root@rlx-3-08 rhn-satellite-prep]# 


As such, we need to update the satellite cobbler installer to write an entry into the rhn-satellite-prep structure so that it is kept during upgrade OR add entry to upgrade steps to manually enter/add the config value :)

Cliff.
Comment 10 Partha Aji 2009-07-14 17:53:32 EDT
Should be fixed in the next release.. as of http://git.fedorahosted.org/git/?p=spacewalk.git;a=commit;h=9a04a11541e09092ee74322ab9b2a480ba6c8056
Comment 11 Sayli Karmarkar 2009-07-17 19:54:45 EDT
Verified on upgrade path: 

Sat 5.2.0 20081028.3 RHEL4 s390x external db -> Sat 5.3.0 RHEL4 s390x 

cobbler.host is correctly initialized after upgrade and system kickstart was successful.
Comment 12 Partha Aji 2009-07-28 09:04:41 EDT
*** Bug 514214 has been marked as a duplicate of this bug. ***
Comment 13 Jeff Browning 2009-07-29 16:03:26 EDT
tested on test04-64.rhndev.redhat.com
Comment 14 Brandon Perkins 2009-08-27 13:38:37 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1235.html

Note You need to log in before you can comment on or make changes to this bug.