Bug 511116 - kickstart fails after upgrade as its pointing to the tinyurl
kickstart fails after upgrade as its pointing to the tinyurl
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
530
All Linux
urgent Severity high
: ---
: ---
Assigned To: Justin Sherrill
Jeff Browning
:
: 511164 (view as bug list)
Depends On:
Blocks: 456986 457075
  Show dependency treegraph
 
Reported: 2009-07-13 14:33 EDT by Preethi Thomas
Modified: 2009-08-27 13:38 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-27 13:38:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2009-07-13 14:33:50 EDT
Description of problem:
kickstart unable to retrieve install image as its pointing to the tinyurl

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL4-re20090709.0-i386-embedded-oracle.iso
rhn-upgrade-5.3.0.16-1.el4sat
How reproducible:


Steps to Reproduce:
1. upgrade a satellite to 5.3 mine is 5.1 to 5.3 on rhel4
2. using the ks-profile from pre upgrade
3. kickstart a client
  
Actual results:
connect to the console of the client
        +------------------------+ HTTP Setup +------------------------+        
        |                                                              |        
        |       Please enter the following information:                |        
        |                                                              |        
        |           o the name or IP number of your Web server         |        
        |           o the directory on that server containing          |        
        |             Red Hat Enterprise Linux for your                |        
        |       architecture                                           |        
        |                                                              |        
        | Web site name:                      -3-08.rhndev.redhat.com_ |        
        | Red Hat Enterprise Linux directory: /ty/cAfCOXpa____________ |        
        |                                                              |        
        |            +----+                       +------+             |        
        |            | OK |                       | Back |             |        
        |            +----+                       +------+     

 +---------------+ Error +----------------+                   
                   |                                        |                   
                   | Unable to retrieve the install image.  |                   
                   |                                        |                   
                   |                +----+                  |                   
                   |                | OK |                  |                   
                   |                +----+                  |                   
                   |                                        |                   
                   |                                        |                   
                   +----------------------------------------+        


it looks like the ks file is pointing to the tinyurl address instead of the cobbler address for the kickstart tree

Expected results:
ks completes


Additional info:

from 
/var/log/httpd/error_log

[Mon Jul 13 13:23:03 2009] [error] [client 10.10.76.140] (70014)End of file found: mod_mime_magic: read failed /var/www/cobbler/images/ks-rhel-i386-as-4-u7/initrd.img
Comment 1 Clifford Perry 2009-07-13 14:52:08 EDT
Needs some investigation.

Cliff
Comment 2 Justin Sherrill 2009-07-13 16:02:40 EDT
So just because it's using /ty isn't wrong.  All reprovisioning and guest provisioning still uses the /ty urls.  Something must have gone wrong during the kickstart and either the httpd config isn't correct, or something is wrong with the networking on the box.
Comment 3 Justin Sherrill 2009-07-13 17:04:18 EDT
So it looks like it's a permissions issue:

[root@rlx-3-08 ~]# ll /var/satellite/rhn/kickstart/ks-rhel-i386-as-4-u7/images/pxeboot/
total 5712
-rw-r-----  3 apache root 4266944 Jul 11  2008 initrd.img
-rw-r-----  1 apache root     288 Jul 11  2008 README
-rw-r-----  3 apache root 1545551 Jul 11  2008 vmlinuz


None of the files in /var/satellite/rhn/kickstart are readable by tomcat (or the apache group).  The directories are fine, but the files themselves are not readable.
Comment 4 Justin Sherrill 2009-07-13 18:03:09 EDT
So the problem was that the kickstart trees in /var/satellite/rhn did not have permissions that allowed tomcat to read them.  I modified updatePackages.py to change their permissions to 644 which is what we do for the other /var/satellite files in that script

65c5bd8
Comment 5 John Matthews 2009-07-14 02:31:29 EDT
*** Bug 511164 has been marked as a duplicate of this bug. ***
Comment 6 Preethi Thomas 2009-07-17 12:51:21 EDT
fails_qa
I still run into the same error. test01-64

[root@test01-64 ~]# ll /var/satellite/rhn/kickstart/ks-rhel-i386-server-5/images/pxeboot/
total 6564
-rw-r--r-- 3 apache root 4918676 Feb  8  2007 initrd.img
-rw-r--r-- 1 apache root     290 Feb  8  2007 README
-rw-r--r-- 3 apache root 1765460 Feb  8  2007 vmlinuz
[root@test01-64 ~]# rpm -q rhn-upgrade
rhn-upgrade-5.3.0.19-1.el5sat
Comment 7 Justin Sherrill 2009-07-20 14:45:30 EDT
Hey Preethi,

test01-64 only has 1 gig of ram, and i think the reason it was failing was because it was timing out when requesting some files.  The load average was between 25 and 30.

Please re-test on a machine with more ram :}

-Justin
Comment 8 Jeff Browning 2009-07-22 11:13:29 EDT
Kickstarts after upgrade no longer point to tiny URL.

Verified.
Comment 9 Jeff Browning 2009-07-22 11:14:59 EDT
Or more to the point, kickstart after upgrade did not get stuck in the above situation.
Comment 10 Sayli Karmarkar 2009-07-29 11:52:42 EDT
validated.
Comment 11 Brandon Perkins 2009-08-27 13:38:40 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1235.html

Note You need to log in before you can comment on or make changes to this bug.