This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 511139 - Brother HL-730 cups driver fails on test
Brother HL-730 cups driver fails on test
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-13 16:50 EDT by ScipioX
Modified: 2009-07-29 03:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-29 03:08:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Brother-HL-730 PPD (19.37 KB, application/vnd.cups-ppd)
2009-07-14 07:19 EDT, Jiri Popelka
no flags Details

  None (edit)
Description ScipioX 2009-07-13 16:50:57 EDT
Description of problem:
Brother HL-730 cups driver fails on test, therefore can not install.

Version-Release number of selected component (if applicable):
cups-1.4-0.b2.18.fc11.i586

How reproducible:
run from shell:
/usr/lib/cups/daemon/cups-driverd cat foomatic:Brother-HL-730-hl7x0.ppd | cupstestppd /dev/stdin

Steps to Reproduce:
1. run from shell:
/usr/lib/cups/daemon/cups-driverd cat foomatic:Brother-HL-730-hl7x0.ppd | cupstestppd /dev/stdin
  
Actual results:
/dev/stdin: FAIL
      **FAIL**  Unable to open PPD file - Illegal translation string on line 64.
                REF: Page 27, section 3.5.


Expected results:
Not FAIL = PASS

Additional info:
-
Comment 1 Jiri Popelka 2009-07-14 07:19:22 EDT
Created attachment 351576 [details]
Brother-HL-730 PPD

Generated by automagic PPD file generator on
http://www.openprinting.org/show_driver.cgi?driver=hl7x0
Comment 2 Jiri Popelka 2009-07-14 07:22:02 EDT
Can you try this PPD file?

It passed cupstestppd:

openprinting_Brother-HL-730-hl7x0.ppd: PASS
        WARN    Non-standard size name "11x17"!
                REF: Page 187, section B.2
Comment 3 ScipioX 2009-07-14 10:52:24 EDT
The attached PPD Passed the test, but cannot print with this PPD.
When I start a print the printer did not print, just the error led start blinking.

$ cupstestppd openprinting_Brother-HL-730-hl7x0.ppd 
openprinting_Brother-HL-730-hl7x0.ppd: PASS
        WARN    Non-standard size name "11x17"!
                REF: Page 187, section B.2.
Comment 4 Jiri Popelka 2009-07-14 11:37:03 EDT
So the foomatic:Brother-HL-730-hl7x0.ppd can't be installed.
The openprinting_Brother-HL-730-hl7x0.ppd can be installed, but the printer is not printing ?

Can you do this steps:
1) yum --enablerepo=updates-testing update 'cups*' 'system-config-printer*'
2) System->Administration->Printing, then Help->Troubleshoot from the menu bar.
Select your Brother-HL-730 printer, enable debugging, try to print test page and save the diagnostic output.
3) Attach the output here.
Comment 5 Jiri Popelka 2009-07-14 12:00:43 EDT
The PPD from openprinting.org is nearly the same, it differs only in 3 lines.

diff foomatic_Brother-HL-730-hl7x0.ppd openprinting_Brother-HL-730-hl7x0.ppd
37a38
> *cupsFilter:	"application/vnd.apple-pdf 25 foomatic-rip"
64c65
< *driverName hl7x0/hl7x0 - Driver for Brother's proprietary printer language (works also on the PCL/PS models): ""
---
> *driverName hl7x0: "Driver for Brother's proprietary printer language (works also on the PCL/PS models)"
374c375
< *ParamCustomPIN PIN/PIN (4 digits, leave blank for unprotected job): 1 4 0 0
---
> *ParamCustomPIN PIN/PIN (4 digits, leave blank for unprotected job): 1 password 0 4
Comment 7 ScipioX 2009-07-14 12:24:28 EDT
I can install the PPD and it works. The steps:

1. start system-config-printer
2. click NEW button
3. Device form select OTHER and fill device uri "parallel:/dev/lp0"
4. click Forward button
5. select Provide a PPD file, and select the PPD file
6. click Forward button
7. in describe printer click Apply button
8. it works

Last time I tried to add the printer from cups admin homepage it wont work.
Comment 8 Tim Waugh 2009-07-14 13:51:06 EDT
The original problem was that the CUPS foomatic driver was generating an incorrect PPD attribute line:

*driverName hl7x0/hl7x0 - Driver for Brother's proprietary printer language
(works also on the PCL/PS models): ""

That seems to be fixed by this update:
  https://admin.fedoraproject.org/updates/F11/FEDORA-2009-7448

Incidentally -- is there a reason you had to type in 'parallel:/dev/lp0' instead of selecting the device from the list?  Was it not in the list?
Comment 9 ScipioX 2009-07-15 15:32:10 EDT
Device was in the list, but if I choose it, the program does not ask me for a driver/model/PPD, and I think it tried to install a bad PPD which is in cups-driverd, and I get an error message.
Comment 10 Tim Waugh 2009-07-17 07:58:39 EDT
Oh, I see. :-(

Perhaps the option to provide your own PPD file should be moved earlier, to the device selection screen.

Note You need to log in before you can comment on or make changes to this bug.