Bug 511142 - F10->F11 upgrade error
F10->F11 upgrade error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:2bac901a7d554b426...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-13 17:05 EDT by Antti Huhtala
Modified: 2009-07-24 14:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-24 14:37:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (1.19 MB, text/plain)
2009-07-13 17:05 EDT, Antti Huhtala
no flags Details

  None (edit)
Description Antti Huhtala 2009-07-13 17:05:07 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/yum/misc.py", line 617, in bunzipFile
    destination.write(data)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 174, in populate
    misc.bunzipFile(db_fn, db_un_fn)
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 260, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 488, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 464, in doSackSetup
    return self._getSacks(archlist=archlist, thisrepo=thisrepo)
  File "/usr/lib/anaconda/yuminstall.py", line 1082, in <lambda>
    self.__withFuncDo(anaconda, lambda r: self.ayum.doSackSetup(thisrepo=r.id),
  File "/usr/lib/anaconda/yuminstall.py", line 1109, in __withFuncDo
    fn(repo)
  File "/usr/lib/anaconda/yuminstall.py", line 1083, in doSackSetup
    thisrepo=thisrepo, fatalerrors=fatalerrors)
  File "/usr/lib/anaconda/yuminstall.py", line 1037, in doBackendSetup
    self.doSackSetup(anaconda)
  File "/usr/lib/anaconda/backend.py", line 271, in doBackendSetup
    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1339, in nextClicked
    self.anaconda.dispatch.gotoNext()
IOError: [Errno 28] Laitteella ei ole tilaa jäljellä
Comment 1 Antti Huhtala 2009-07-13 17:05:27 EDT
Created attachment 351527 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-07-17 15:43:23 EDT
How big are your filesystems?
Comment 3 Antti Huhtala 2009-07-17 16:19:02 EDT
A good question. It turned out that preupgrade files had filled up my root directory which was only 10 Gb large. That is why my first try to upgrade failed.
However, after repartitioning sdb, my second hard disk, (and reinstalling F10) to allow 1 Gb for /boot, 20 Gb for /home, 20 Gb for / (root directory) and 5 Gb for swap, and trying preupgrade again, it still did not succeed. This time the problem evidently is in building the upgrade directory tree.
This is a triple-boot system with Windows XP and F9 on sda and F10 on sdb. It looks like the upgrade directory tree is built partially on sda and partially on sdb and, upgrade installation fails after reboot.
Because this latter upgrade problem is different from the anaconda-generated error report above, I probably should close this bug and file another against preupgrade. Do you agree?
Comment 4 Chris Lumens 2009-07-17 16:30:13 EDT
That sounds reasonable to me.
Comment 5 Denise Dumas 2009-07-24 14:37:57 EDT
Based on comment 3, I'm assuming antti opened a preupgrade BZ and I'm going to close this bug.

Note You need to log in before you can comment on or make changes to this bug.