Bug 511149 - Failed to bring back PF interface while guest OS running
Failed to bring back PF interface while guest OS running
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks: 533192
  Show dependency treegraph
 
Reported: 2009-07-13 17:53 EDT by sibai.li
Modified: 2009-11-05 10:14 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-28 13:24:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sibai.li 2009-07-13 17:53:57 EDT
Description of problem:
Failed to bring back PF interface while guest OS running

Version-Release number of selected component (if applicable):

SR-IOV PF driver 1.3.16-k2

How reproducible:
With at least one guest OS running, PF driver seems in malfunction
 when the network interface is brought down, then up.
 1. ifdown eth1 
 2. ifconfig eth1 192.168.1.200

 "SIOCSIFFLAGS: Cannot allocate memory"

 3. From dmesg log, the error msg

 "igb 0000:01:00.0: Unable to allocate memory for the transmit descriptor ring
 igb 0000:01:00.0: Allocation for Tx Queue 0 failed"

 4. From VF side, it complied " PF is in resetting"
 5. if all guest OSes got killed, PF driver working again.


  
Actual results:
Failed

Expected results:
After the PF interface back. The VF should fuctional.

Additional info:
Comment 1 Andy Gospodarek 2009-07-14 11:07:04 EDT
Does this work correctly on a recent upstream kernel?
Comment 2 sibai.li 2009-07-15 18:53:21 EDT
sli6 7/7/2009 11:09:47 AM

The defect only ocurs on PF driver of RHEL5.4.
I tested it on XEN3.4.1 with latest PF driver 1.3.28.1.
The defect doesn't occur on the PF driver 1.3.28.1 on XEN 3.4.1.

gvrose 7/14/2009 4:34:08 PM

The bug is reproducible using Intel igb PF driver 1.3.30 and igbvf VF driver 1.0.2.  Using these same drivers on Xen 3.4.1 the problem does not occur so this would indicate that the issue results from some interaction with the system that is unique to RHEL 5.4.  As noted in the description its a fairly simple memory allocation problem.  The driver requests DMA memory and the request fails.
Comment 3 sibai.li 2009-07-17 20:42:32 EDT
The problem is reproduced on two systems, when only one VM with one VF is running.

I tested on my system. When one VM with one VF is running, the defect can not be produced on this system.
However after I create 14 VMs, then destroy a VM, after this, create a VM.
If bring the PF interface down and up. The defect occurs.
Here is the dmseg
igb 0000:01:00.0: Unable to allocate memory for the transmit descriptor ring
igb 0000:01:00.0: Allocation for Tx Queue 0 failed
pciback: vpci: 0000:01:10.0: assign to virtual slot 0
igb 0000:01:00.0: Unable to allocate memory for the transmit descriptor ring
igb 0000:01:00.0: Allocation for Tx Queue 0 failed
Comment 4 Don Dugger 2009-10-19 12:36:17 EDT
Sibai-

I understand that this bug is not reproducible in RHEL 5.4 GA.  Can you verify that this is the case and then we can close the bug.
Comment 5 sibai.li 2009-10-28 13:23:56 EDT
The defect is fixed, close it

Note You need to log in before you can comment on or make changes to this bug.