Bug 511157 - Udev loads too long on boot
Udev loads too long on boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-13 19:07 EDT by Krzesimir Nowak
Modified: 2009-08-08 15:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-15 02:35:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot.log (46.23 KB, text/plain)
2009-07-13 19:07 EDT, Krzesimir Nowak
no flags Details
udev.log (38.78 KB, application/x-bzip)
2009-07-14 08:52 EDT, Krzesimir Nowak
no flags Details

  None (edit)
Description Krzesimir Nowak 2009-07-13 19:07:00 EDT
Created attachment 351534 [details]
boot.log

Description of problem:
After upgrading udev to version in test-updates, it loads 3 minutes. After changing kernel option from `quiet' to `udevinfo' and option in udev.conf to `info', screen is flooded with informations from udev, while it loads on boot. Informations scroll too fast to read anything.


Version-Release number of selected component (if applicable):
udev - 141-4.fc11
kernel-PAE - 2.6.29.5-191.fc11

How reproducible:
By booting.

Steps to Reproduce:
1. Boot.
2.
3.
  
Actual results:
Udev loads too long.

Expected results:
Udev loads quickly.

Additional info:
I'm attaching my boot.log, but it shows only the end of boot, so only a tiny part of udev informations are there. If any other info is needed, I'll try to provide it.
Comment 1 Harald Hoyer 2009-07-14 06:19:36 EDT
Can you please install udev-141-5 from:
https://koji.fedoraproject.org/koji/buildinfo?buildID=114226

and start with the kernel command line "udevinfo udevlog"

then you can attach the file /dev/.udev/udev.log which should contain a complete log.
Comment 2 Krzesimir Nowak 2009-07-14 08:52:25 EDT
Created attachment 351580 [details]
udev.log

Packed udev.log, because unpacked weights nearly 700kb.
Comment 3 Harald Hoyer 2009-07-14 09:05:18 EDT
It might be, that this takes so long.. Can you try it?
# time create_floppy_devices -c -t  -m 2 -M 0640 -G floppy /dev/fd0

Do you have your floppy enabled in the BIOS and no real floppy drive?
Comment 4 Harald Hoyer 2009-07-14 09:09:44 EDT
ah, should be:

# time /lib/udev/create_floppy_devices -c -t  -m 2 -M 0640 -G floppy /dev/fd0
Comment 5 Krzesimir Nowak 2009-07-14 09:49:54 EDT
Corrected command was also wrong - `-t' didn't have an argument. Anyway, command executed quickly:

[kudi@fiodor ~]$ time /lib/udev/create_floppy_devices -c -t 2 -m 2 -M 0640 -G gloppy /dev/fd0

real	0m0.154s
user	0m0.056s
sys	0m0.010s

My computer is laptop - Dell Latitude C610 (probably about 6 years old). I don't have any floppy drives installed and BIOS also tells me so.
Comment 6 Harald Hoyer 2009-07-14 10:25:44 EDT
Hmm, it seems that your BIOS reports a floppy...

[194] util_run_program: '/sbin/modprobe -b acpi:PNP0700:'

You can check it with:
# find /sys -name modalias | xargs grep -l PNP0700

Workaround for your buggy BIOS:

# echo "blacklist floppy" > /etc/modprobe.d/blacklist-floppy.conf
Comment 7 Harald Hoyer 2009-07-14 10:26:07 EDT
Hope this resolves the issue.
Comment 8 Krzesimir Nowak 2009-07-14 13:05:51 EDT
Yes, now it loads quickly as it should. Thanks for help!

(Strange that udev was sensitive to my buggy BIOS now, not earlier.)
Comment 9 Harald Hoyer 2009-07-15 02:35:37 EDT
well, I fixed floppy autoloading in the new version :)

Note You need to log in before you can comment on or make changes to this bug.