Bug 511163 - setroubleshoot: SELinux is preventing pulseaudio (nsplugin_t) "execute" pulseaudio_exec_t.
setroubleshoot: SELinux is preventing pulseaudio (nsplugin_t) "execute" ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:3ecd963c427...
:
: 511165 511166 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-13 19:58 EDT by Sachin Garg
Modified: 2009-08-21 17:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-21 17:52:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachin Garg 2009-07-13 19:58:41 EDT
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing pulseaudio (nsplugin_t) "execute" pulseaudio_exec_t.

Detailed Description:

[SELinux is in permissive mode, the operation would have been denied but was
permitted due to permissive mode.]

SELinux denied access requested by pulseaudio. It is not expected that this
access is required by pulseaudio and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c102
                              3
Target Context                system_u:object_r:pulseaudio_exec_t:s0
Target Objects                /usr/bin/pulseaudio [ file ]
Source                        pulseaudio
Source Path                   /usr/bin/pulseaudio
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           pulseaudio-0.9.16-2.test2.fc12
Target RPM Packages           pulseaudio-0.9.16-2.test2.fc12
Policy RPM                    selinux-policy-3.6.21-3.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-0.62.rc2.git4.fc12.i586
                              #1 SMP Thu Jul 9 22:19:03 EDT 2009 i686 i686
Alert Count                   3
First Seen                    Mon 13 Jul 2009 06:56:44 PM CDT
Last Seen                     Mon 13 Jul 2009 06:56:44 PM CDT
Local ID                      8d1fadb9-0f78-4746-a941-a0a0d46c8638
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1247529404.21:22): avc:  denied  { execute } for  pid=1487 comm="npviewer.bin" name="pulseaudio" dev=sda6 ino=45692 scontext=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:pulseaudio_exec_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1247529404.21:22): avc:  denied  { read open } for  pid=1487 comm="npviewer.bin" name="pulseaudio" dev=sda6 ino=45692 scontext=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:pulseaudio_exec_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1247529404.21:22): avc:  denied  { execute_no_trans } for  pid=1487 comm="npviewer.bin" path="/usr/bin/pulseaudio" dev=sda6 ino=45692 scontext=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:pulseaudio_exec_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1247529404.21:22): arch=40000003 syscall=11 success=yes exit=0 a0=b0f012e8 a1=b1a35cbc a2=bf92621c a3=91b2128 items=0 ppid=1451 pid=1487 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="pulseaudio" exe="/usr/bin/pulseaudio" subj=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= nsplugin_t ==============
allow nsplugin_t pulseaudio_exec_t:file { read execute open execute_no_trans };
Comment 1 Daniel Walsh 2009-07-14 12:12:56 EDT
*** Bug 511166 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Walsh 2009-07-14 12:13:17 EDT
*** Bug 511165 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Walsh 2009-08-21 17:52:55 EDT
Fixed in selinux-policy-3.6.28-4.fc12.noarch

Note You need to log in before you can comment on or make changes to this bug.