Bug 51118 - No keyboard or mouse funtionality
No keyboard or mouse funtionality
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-07 11:18 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-23 12:45:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-07 11:18:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Ever since kernels post the official Redhat 7.1 release, I cannot get 
either keyboard or mouse functionality after installation is complete.  
Keyboard functionality still exists until XWindows starts up.  Once the 
GUI logon screen appears, there is absolutely zero keyboard or mouse 
functionality.  The problem still exists with the Roswell beta release.  
Maybe this is just an XFree86 issue.

How reproducible:
Always

Steps to Reproduce:
1. After installing Redhat 7.1 (set KDE as default GUI) , apply all the 
updates, and update the kernel.  reboot.  No keybord or mouse 
functionality at logon screen.  OR 
2. Install Redhat Roswell beta then (set KDE as default GUI) reboot.  Same 
thing - no keyboard or mouse functionality at logon screen.
3.
	

Actual Results:  Exactly what's stated

Expected Results:  I should have keyboard and mouse control; otherwise, 
the system is pretty damn useless.

Additional info:

Motherboard: Asus TX97-E with latest BIOS
Processor: Intel Pentium 233 MMX
Keyboard: Compaq keyboard
Mouse: Logitech Firstmouse+Wheel
SCSI Host Adapters: Adaptech 2940UA
Drives: Quantum 4.3 GB SCSI <--- Where Linux is installed
        Western Digital 2.5 GB EIDE <--- Where WinME is installed
        Mitsumi 8x SCSI CD-ROM
        IOMEGA 1 GB JAZZ SCSI
        IOMEGA ZIP 100 SCSI
        1.44 MB Floppy Drive
Video: ATI Expert@Play 98 (Rage PRO Turbo)
Network: NetGear FA310TX
Modem: 3Com/USR 33.6 K D/V/F Internal ISA
Comment 1 Larry A. Stein 2001-11-02 10:30:47 EST
Having a similar problem (beginning with 7.1b - no problems with 7.0 and 
earlier releases). Description above is exactly what I'm getting.

Running an *old* machine (P166) with hardware that should -definitely- be 
compatible - no recently released or obscure hardware here that could be 
causing a conflict.

(While rebooting immediately after installation, Kudzu pops up and tells me that
my PS/2 mouse has been removed from the system. --???)

After that, anything that attempts to access the mouse freezes the mouse and 
keyboard, whether X is running or not. If I ssh or telnet in and kill off 
whatever process is trying to access the mouse, I get the keyboard back.

No problems with RH 7.0 and earlier - problem with mouse driver?
Trying other linux distributions to see if it's strictly a problem with this 
distribution or if it's a problem with the new kernel.
Comment 2 Need Real Name 2002-01-20 14:30:52 EST
	I installed Red Hat 7.2 on an E-Machine 600id desktop (with the following additions: Microsoft 
PS/2  compatible
IntelliMouse model 1.1A;  a Diamond Monster Voodoo based acceleration video 
card; Lite-On 16x10x40 CD-RW; an  extra 128 MB
RAM).  The only important item, I believe, in the 
previous list is the MS IntelliMouse.  Here's the meat of my  message:

	RH 7.2 did not detect my 
mouse correctly.  So I corrected it and choose the IntelliMouse protocol.  The  installation on 
a
whole went well until I tried to reboot.  Once I was even at the command line, I lost function of 
both the  keyboard and the mouse. 
This has only been effectually corrected by entering 
interactive mode and disabling GPM.  This, however, does not  correct the
XFree86 problem.  If I 
'startx' I always lose the keyboard and the mouse, even though all was well immediately  after the 
installation.  I
was able to explore and enjoy the newer release of gnome and my sound card even 
worked along with the wheel on  the mouse.
	Well, in my frustration I reinstalled SuSE 7.0.  I 
forgot about all my previous experiences with it, and  every other distribution:

"don't 
chose the IntelliMouse protocol when setting up the mouse!"

The reason being is that I ended 
up with the exact same problem in SuSE 7.0 as in Red Hat 7.2: lose of mouse and  keyboard
function 
after having choosen the IntelliMouse protocol for the mouse set up.  (the result was the same for 
Gnome  and KDE2)
	I won't know until Tuesday, when I get my disks back, whether or not this will 
make the difference for me  or not.  I will let
you know.

Thank you,

William 
Totman
Arlington, TX
Comment 3 Need Real Name 2002-01-20 14:30:58 EST
	I installed Red Hat 7.2 on an E-Machine 600id desktop (with the following additions: Microsoft 
PS/2  compatible
IntelliMouse model 1.1A;  a Diamond Monster Voodoo based acceleration video 
card; Lite-On 16x10x40 CD-RW; an  extra 128 MB
RAM).  The only important item, I believe, in the 
previous list is the MS IntelliMouse.  Here's the meat of my  message:

	RH 7.2 did not detect my 
mouse correctly.  So I corrected it and choose the IntelliMouse protocol.  The  installation on 
a
whole went well until I tried to reboot.  Once I was even at the command line, I lost function of 
both the  keyboard and the mouse. 
This has only been effectually corrected by entering 
interactive mode and disabling GPM.  This, however, does not  correct the
XFree86 problem.  If I 
'startx' I always lose the keyboard and the mouse, even though all was well immediately  after the 
installation.  I
was able to explore and enjoy the newer release of gnome and my sound card even 
worked along with the wheel on  the mouse.
	Well, in my frustration I reinstalled SuSE 7.0.  I 
forgot about all my previous experiences with it, and  every other distribution:

         "don't 
chose the IntelliMouse protocol when setting up the mouse!"

The reason being is that I ended 
up with the exact same problem in SuSE 7.0 as in Red Hat 7.2: lose of mouse and  keyboard
function 
after having choosen the IntelliMouse protocol for the mouse set up.  (the result was the same for 
Gnome  and KDE2)
	I won't know until Tuesday, when I get my disks back, whether or not this will 
make the difference for me  or not.  I will let
you know.

Thank you,

William 
Totman
Arlington, TX
Comment 4 Need Real Name 2002-01-23 12:45:23 EST
My problem has been solved simply by going with what Red Hat 7.2 detected automatically during 
the install instead of trying to tell it that my mouse was an MS IntelliMouse.  Therefore the 
protocol was changed and everything works fine.  However I did for get to test whether the iwheel 
was wroking or not.  If not then I expect I can cut and paste from the first XFConfig-4 that I got from 
the first install to, hopefully add support for it.

Note You need to log in before you can comment on or make changes to this bug.