Bug 511255 - Network warning have some delay when refresh
Network warning have some delay when refresh
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-14 09:12 EDT by Mark Xie
Modified: 2010-11-09 08:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-07 15:11:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Xie 2009-07-14 09:12:04 EDT
Description of problem:
The warning will not correct when adding virtual network.

Version-Release number of selected component (if applicable):
virt-manager-0.6.1-6.el5

How reproducible:
100%

Steps to Reproduce:
1. Launch virt-manager
2. Open "Host Details" window by "Edit --> Host Details", go to page of
"Virtual Networks"
3. Add a new network follow the wizard, specify "192.168.0.0/24" on page of "Choosing an IPv4 address space".
4. Change "192.168.0.0/24" to "192.168.0.0/23", then change to "192.168.0.0/22"......"192.168.0.0/13"
5, Change to "192.168.0.0/12"
6, Cancel the "Create new virtual network" window and add a new one, specify the "192.168.0.0/15" on page of "Choosing an IPv4 address space".
  
Actual results:
There is none warning at step 3 and step 4. 
There will be warning at step 5.
There will be warning at step 6.

Expected results:
But the largest CIDR block (subnet mask) is 192.168.0.0/16 (255.255.0.0)

Additional info:	
This condition also happens on 10.0.0.0/8 private network, the user can specify 10.0.0.0/7
Comment 3 Cole Robinson 2010-04-07 15:11:39 EDT
The reporters analysis wasn't correct: 192.168.0.0/13 is a valid CIDR block.

168 as a bit mask looks like: 10101000

This means the bottom 3 bits aren't required to specify the network address (if assumed to be all 0). This means only 12 total bits are required to specify the network address (8 for 192, 4 for 168). That means any host mask from /32 to /13 is valid, but anything less is an error.

Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.