Bug 51126 - Pasting from opera to rxvt fails after upgrade to Roswell - rxvt-2.6.3-2 works
Pasting from opera to rxvt fails after upgrade to Roswell - rxvt-2.6.3-2 works
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: rxvt (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-07 14:31 EDT by Ville Herva
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-07 14:37:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Herva 2001-08-07 14:31:04 EDT
Description of Problem:
I recently upgraded most of my stuff to latest rawhide (roswell or newer). This included all the kde stuff kde (I was running 2.2.0alpha), rxvt, glibc and all the gnome stuff. I didn't update qt, since it was already up-to-date.

After that, I can no longer paste from opera (5.0 statically linked qt) to rxvt (2.7.6-4). Of course this used to work. If I press shift-ins or middle button, nothing happens.

I _can_ paste from opera to xterm, kterm etc.

I _can_ paste from konqueror, galeon, mozilla to rxvt.

I tried going back to rh7.1 rxvt (2.7.5-15), but that had didn't help. I'm not sure, though, what version of rxvt I used to have.

I do realize opera is binary only bleah bleah, but it used to work.

ldd =opera 
        libm.so.6 => /lib/libm.so.6 (0x40029000)
        libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x4004d000)
        libpng.so.2 => /usr/lib/libpng.so.2 (0x4006c000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x4008d000)
        libdl.so.2 => /lib/libdl.so.2 (0x400a4000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x400a8000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x40194000)
        libXmu.so.6 => /usr/X11R6/lib/libXmu.so.6 (0x401a3000)
        libc.so.6 => /lib/libc.so.6 (0x401bb000)
        libz.so.1 => /usr/lib/libz.so.1 (0x402f7000)
        libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x40305000)
        libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x40358000)
        libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x40361000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

of those, afaik only libc was updated. Not a likely candidate.

ldd =rxvt 
        libXpm.so.4 => /usr/X11R6/lib/libXpm.so.4 (0x40017000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x40028000)
        libutempter.so.0 => /usr/lib/libutempter.so.0 (0x40126000)
        libutil.so.1 => /lib/libutil.so.1 (0x40128000)
        libc.so.6 => /lib/libc.so.6 (0x4012b000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

again, only glibc updated.

I'm out of clues.
Comment 1 Ville Herva 2001-08-07 14:37:11 EDT
I found the old rxvt on my backup (luckily online). It's version is 2.6.3-2
and it works.

While we're at it, colors on 2.7.5-15, 2.7.6-4 appear quite different from those of 2.6.3-2 (and older ones I used to have).

I still don't understand how rxvt might refuse pasting from one specific 
app. Then again, I'm having big trouble pasting and copying from rxvt on
windows as well (be it rxvt/xygwin/x or rxvt/cygwin/native), so perhaps there is something rotten in rxvt X selection code...

Perhaps I should take this up on rxvt mailing list...

Comment 2 Harald Hoyer 2001-08-08 08:27:35 EDT
tried and it works... rxvt and opera ...

Note You need to log in before you can comment on or make changes to this bug.