Bug 511269 - Error while adding iSCSI device
Error while adding iSCSI device
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
5.5
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Mike Christie
Red Hat Kernel QE team
anaconda_trace_hash:c521e7e1c711b23dc...
:
Depends On: 485217
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-14 10:25 EDT by Joey Boggs
Modified: 2009-07-14 10:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 485217
Environment:
Last Closed: 2009-07-14 10:26:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joey Boggs 2009-07-14 10:25:34 EDT
+++ This bug was initially created as a clone of Bug #485217 +++

This bug was filed automatically by anaconda.

--- Additional comment from jlaska@redhat.com on 2009-02-12 08:32:04 EDT ---

Created an attachment (id=331689)
Attached traceback automatically from anaconda.

--- Additional comment from jlaska@redhat.com on 2009-02-12 09:15:59 EDT ---

Posting traceback for quick review ...

anaconda 11.5.0.17 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iscsi.py", line 244, in addTarget
    authinfo=authinfo)
  File "/usr/lib/anaconda/iw/autopart_type.py", line 295, in addIscsiDrive
    self.intf)
  File "/usr/lib/anaconda/iw/autopart_type.py", line 361, in addDrive
    rc = self.addIscsiDrive()
TypeError: argument 3 must be libiscsi.chapAuthInfo, not None

--- Additional comment from hdegoede@redhat.com on 2009-02-12 10:34:20 EDT ---

This is not an anaconda issue, but an issue with the python bindings for libiscsi, changing component to iscsi-initiator-utils and assigning to myself.

--- Additional comment from hdegoede@redhat.com on 2009-02-12 10:46:43 EDT ---

Fixed in 6.2.0.870-4, closing.

mchristie, when you move libiscsi upstream please do not forget to add this patch (see Fedora cvs).

--- Additional comment from jlaska@redhat.com on 2009-02-12 10:50:32 EDT ---

FYI ... updates image to work around this issue available at http://people.atrpms.net/~hdegoede/updates485217.img

--- Additional comment from hdegoede@redhat.com on 2009-02-12 11:12:51 EDT ---

(In reply to comment #5)
> FYI ... updates image to work around this issue available at
> http://people.atrpms.net/~hdegoede/updates485217.img

FYI this is i386 only!
Comment 1 Joey Boggs 2009-07-14 10:26:50 EDT
this bz was supposed to be a clone of another one but somehow grabbed the wrong bz id, closing

Note You need to log in before you can comment on or make changes to this bug.