Bug 51128 - mouseconfig fails to undo 3-button emulation
mouseconfig fails to undo 3-button emulation
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mouseconfig (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-07 14:47 EDT by Rabbe Fogelholm
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rabbe Fogelholm 2001-08-07 14:47:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010803

Description of problem:
Unticking the "Emulate 3 Buttons" field has no effect on the generated
XF86Config file under certain circumstances.

How reproducible:
Always

Steps to Reproduce:
1. Run mouseconfig with no arguments and pretend you have a "Generic 3
Button Mouse (PS/2)", and untick the "Emulate 3 Buttons" field. This
produces an XF86Config file where Emulate3Buttons and Emulate3Timeout are
commented out.

2.Next, run mouseconfig with no arguments and pretend you have a "Generic
Mouse (PS/2)", and tick the "Emulate 3 Buttons" field. This produces an
XF86Config file where Emulate3Buttons and Emulate3Timeout are active. This
proves that mouseconfig in some cases does manipulate the Emulate3Buttons
and Emulate3Timeout lines.

3.Finally run mouseconfig with no arguments and pretend you have a "Generic
Mouse (PS/2)" just like before, and *untick* the "Emulate 3 Buttons" field.
This produces an XF86Config file where Emulate3Buttons and Emulate3Timeout
are still active (in fact the XF86Config file has not changed at all).
	

Actual Results:  You are left with an XF86Config file where Emulate3Buttons
and Emulate3Timeout are still active, although they should have been
commented out.

Expected Results:  The Emulate3Buttons and Emulate3Timeout lines should
have been commented out.

Additional info:
Comment 1 Brent Fox 2002-10-10 14:15:20 EDT
I have just completed a text mode interface for redhat-config-mouse, which means
that mouseconfig will be deprecated in the next release of Red Hat Linux.  

Therefore, I will not be putting any development time towards fixing mouseconfig
bugs, so I'm closing this as 'wontfix'.
Comment 2 Red Hat Bugzilla 2006-02-21 13:48:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.