Bug 511284 - Only video mode/resolution detected is 1680x1050 (default)
Only video mode/resolution detected is 1680x1050 (default)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-14 11:08 EDT by Larry O'Leary
Modified: 2018-04-11 12:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-28 12:01:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.log with normal boot (74.58 KB, text/plain)
2009-07-14 11:08 EDT, Larry O'Leary
no flags Details
Xorg.log with nomodeset kernel param (546.79 KB, text/plain)
2009-07-14 11:09 EDT, Larry O'Leary
no flags Details

  None (edit)
Description Larry O'Leary 2009-07-14 11:08:31 EDT
Created attachment 351598 [details]
Xorg.log with normal boot

Description of problem:

The only supported video resolution detected for my laptop monitor is 1680x1050 which is the "best" resolution for the monitor (but not my eyes).


Version-Release number of selected component (if applicable):

kernel 2.6.29.5-191.fc11.x86_64
xorg-x11-drv-intel 2.7.0.7.fc11

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)



How reproducible:

Start Fedora 11 after a standard install.  This issue occurs every time.

Steps to Reproduce:
1. Boot Fedora 11 normally.
2. Attempt to change resolution using System -> Preferences -> Display
3. Use xrandr to display available video modes.
  
Actual results:

System -> Preferences -> Display shows only 1680x1050 as an available resolution regardless of Refresh Rate of 60Hz or 50Hz.

xrandr output:

Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 4096 x 4096
LVDS1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1680x1050      60.1*+   50.1  


Expected results:

Many different screen resolutions as appeared in Fedora 10.

Additional info:

If I reboot with the Kernel parameter nomodeset all expected resolutions appear but other problems exist when selecting these other resolutions, like even though it is a widescreen display, any resolution other than the default 1680 x 1050 shows as standard screen size instead of wide (black bars on left and right of screen.

I will attached the relevant xorg logs.
Comment 1 Larry O'Leary 2009-07-14 11:09:05 EDT
Created attachment 351599 [details]
Xorg.log with nomodeset kernel param
Comment 2 Kieran Clancy 2009-08-17 02:52:19 EDT
Duplicate of bug 503171 ?
Comment 3 Matěj Cepl 2009-08-17 17:44:40 EDT
Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x26) [0x4e89b6]
1: /usr/bin/Xorg(xf86SigHandler+0x6f) [0x47d63f]
2: /lib64/libc.so.6 [0x3a79c33370]
3: /usr/lib64/dri/i915_dri.so [0x7f7981c252c2]
4: /usr/lib64/dri/i915_dri.so(i915UpdateTextureState+0x6a) [0x7f7981c25765]
5: /usr/lib64/dri/i915_dri.so [0x7f7981c4d441]
6: /usr/lib64/dri/libdricore.so(_tnl_draw_prims+0xa6e) [0x7f79818e98b6]
7: /usr/lib64/dri/libdricore.so [0x7f79818e1222]
8: /usr/lib64/xorg/modules/extensions//libglx.so [0x7f79938aad8b]
9: /usr/lib64/xorg/modules/extensions//libglx.so [0x7f79938a5713]
10: /usr/lib64/xorg/modules/extensions//libglx.so [0x7f79938a9839]
11: /usr/bin/Xorg(Dispatch+0x384) [0x446ee4]
12: /usr/bin/Xorg(main+0x3b5) [0x42d0d5]
13: /lib64/libc.so.6(__libc_start_main+0xfd) [0x3a79c1ea2d]
14: /usr/bin/Xorg [0x42c559]

Fatal server error:
Caught signal 11.  Server aborting
Comment 4 Matěj Cepl 2009-08-17 18:19:17 EDT
(In reply to comment #2)
> Duplicate of bug 503171 ?  

Most likely not, I don't see any backtrace over there.
Comment 5 Adam Jackson 2009-08-28 12:01:39 EDT
(In reply to comment #0)
> The only supported video resolution detected for my laptop monitor is 1680x1050
> which is the "best" resolution for the monitor (but not my eyes).

If you want the display to look bigger, set your fonts bigger.  Setting a non-native resolution really only serves to make the display look fuzzy.

> If I reboot with the Kernel parameter nomodeset all expected resolutions appear
> but other problems exist when selecting these other resolutions, like even
> though it is a widescreen display, any resolution other than the default 1680 x
> 1050 shows as standard screen size instead of wide (black bars on left and
> right of screen.

You can change the scaling property of a display with the xrandr command line tool: xrandr --output LVDS1 --set scaling full

Non-native resolutions work again in F12 though.

Note You need to log in before you can comment on or make changes to this bug.