Bug 511290 - lots of unused patches clutter the devel branch directory
lots of unused patches clutter the devel branch directory
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vym (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-14 11:44 EDT by Till Maas
Modified: 2009-08-04 15:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-15 09:40:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2009-07-14 11:44:29 EDT
Description of problem:
There are a lot of unused patches in the devel branch directory. Please remove unused ones with "cvs rm -f *.patch; cvs commit".

There is also a makefile target to show unused patches btw:
make unused-patches
Comment 1 Gwyn Ciesla 2009-07-14 13:39:39 EDT
Once upon a time I was asked not to delete unused patches, as there was some value in their presence for reference.  Does this solve any problems other than aesthetic ones?

BTW, I've no objection to removing them, I'm just curious as to the rationale.
Comment 2 Till Maas 2009-07-15 05:12:15 EDT
(In reply to comment #1)
> Once upon a time I was asked not to delete unused patches, as there was some
> value in their presence for reference.  Does this solve any problems other than
> aesthetic ones?

It makes it easier to get a overview of a packages state in Fedora, e.g. when I looked into the branch because of an upstream bug report, I was overwhelmed by the huge amount of patches, because it was not directly clear to me, that they are not applied.

Btw. upstream seems to release some stable bugfix releases only at http://download.opensuse.org/repositories/home://insilmaril/openSUSE_11.1/src/

E.g. there is a new version that fixes the openoffice export in vym. The thread that made me aware of this starts here:
https://sourceforge.net/mailarchive/forum.php?thread_name=20090710094832.12ad86ac%40shrek&forum_name=vym-forum

And deleted files from CVS can easily be viewed using viewvc:
http://cvs.fedoraproject.org/viewvc/rpms/vym/devel/
If there are deleted files, viewvc shows a link like "there are XX dead files, show them".
Comment 3 Gwyn Ciesla 2009-07-15 09:06:05 EDT
Makes sense, patches removed and committed.  Thanks for the viewvc tip, I've not used it much.

What do you think the odds are that they'll produce an SF release for that?  I'll patch if I need to, obviously, but I'd rather rely on SF, which is the publically-known upstream distribution point, than something in another distro.  I'm upstream for a few packages, and I always keep SF and Fedora in sync. . .
Comment 4 Till Maas 2009-07-15 09:33:55 EDT
(In reply to comment #3)

> What do you think the odds are that they'll produce an SF release for that? 
> I'll patch if I need to, obviously, but I'd rather rely on SF, which is the
> publically-known upstream distribution point, than something in another distro.
>  I'm upstream for a few packages, and I always keep SF and Fedora in sync. . .  

I am not sure. But there seem to have been eight intermediate releases not being  published on SF, but maybe the situation improves know that I asked, what is happening there. :-)
Comment 5 Gwyn Ciesla 2009-07-15 09:40:27 EDT
That'd be ideal. :)  Would you file a bug against vym in which we can track the progress of the release issue?  I'm closing this one, since it's complete.
Comment 6 Till Maas 2009-07-15 13:14:44 EDT
(In reply to comment #5)
> That'd be ideal. :)  Would you file a bug against vym in which we can track the
> progress of the release issue?  I'm closing this one, since it's complete.  

He just replied on the mailinglist, therefore I guess an extra bug is currently not needed. The reason for the missing SF.net releases is the sucking release creation interface at SF.net. Do you maybe know a CLI tool to create such releases?

Btw. there is now an updated vym-1.12.2 tarball available at SF.net.
Comment 7 Gwyn Ciesla 2009-07-15 13:23:15 EDT
No, put I've never found it that hard.  

I see the new files.  I suppose there's an astoundingly awesome reason they couldn't bump the version number?
Comment 8 Till Maas 2009-08-03 07:53:15 EDT
The version number will now be bumped, but still tarballs won't be released at sf.net regularly. If you create a opensuse build service, you can access the current tarball at:
https://api.opensuse.org/source/home:insilmaril/vym/vym-1.12.4.tar.bz2

If you want, I can add vym to the upstream release monitoring[0], so you get a new bug report, if a new version is available. I can also download and add the tarballs for you to the CVS, if you do not want to create a opensuse build service account.
Eventually, there will be also more updates at sf.net again.

[0] https://fedoraproject.org/wiki/Upstream_Release_Monitoring
Comment 9 Gwyn Ciesla 2009-08-03 14:58:18 EDT
I'd really rather have the release available somewhere more public, so as to allow for a proper Source0:.  

URM would be great.  I assume you'll point it at SF, not OpenSUSE?

For the time being, I really would prefer not to create a build service account.  Is there a publicly accessible way to get at that tarball?
Comment 10 Till Maas 2009-08-03 15:11:40 EDT
Currently you can only get it from the src.rpm:
http://download.opensuse.org/repositories/home://insilmaril/openSUSE_11.1/src/

But hopefully it will soon be available, because the sf.net file release process has changed recently and now only requires to upload via scp/sftp/whatever, which should be easy enough that upstream will perform this regularly. I guess I will hear from upstream within the next days about this.

I intended to point URM to OpenSUSE to easier spot it, when a sf.net release is missing.
Comment 11 Gwyn Ciesla 2009-08-04 14:19:58 EDT
Building in rawhide and documenting the sitch in the spec.  Thanks!
Comment 12 Till Maas 2009-08-04 14:35:50 EDT
The version should be ok for the stable releases, too. Also there was a request on the mailing list for an updated package especially for Fedora, because it fixes openoffice export.
Comment 13 Gwyn Ciesla 2009-08-04 15:22:56 EDT
Build and bodhi'd for 10 and 11.

Note You need to log in before you can comment on or make changes to this bug.