Bug 51130 - Major problems with printing setup
Major problems with printing setup
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: printconf (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-07 14:53 EDT by redtux
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-13 09:29:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description redtux 2001-08-07 14:53:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.1)
Gecko/20010607 Netscape6/6.1b1

Description of problem:
There seems to be majorproblems with setting up printing in roswell.
This could be a problem with LPRng, printconf, alchemist,magicdev packages

1. Setting up printers
When you add a printer using printconf-gui you can setup it up, but cannot
edit description (need to use printconf-tui)

2.Test pages do not work

3. Cannot setup new queues using printconf-tui

4. Each page is spooled seperately unless you downgrade the print quality.

5. When print quality is set to draft text is illegible

6. When paper size is set to A4 only half the width of the page is printed.

Everything works after reinstalling magicdev,LPRng and printconf-gui from RH7.1


How reproducible:
Always

Steps to Reproduce:
1. See text
2.
3.
	

Additional info:
Comment 1 Glen Foster 2001-08-07 16:08:45 EDT
We (Red Hat) should really try to fix this before next release.
Comment 2 Crutcher Dunnavant 2001-08-08 15:35:40 EDT
problems 1&2 are fixed, 3&4 is outside of my abbility to change, and I am
looking at 5 now.
Comment 3 Crutcher Dunnavant 2001-08-08 16:10:32 EDT
make that 123 is fixed, 4&5 unchangeable, 6 is being investigated
Comment 4 redtux 2001-08-09 18:11:37 EDT
What is the problem with 4 & 5 - is it the driver? or something else
Comment 5 Crutcher Dunnavant 2001-08-10 19:07:35 EDT
yes. Those are an issue with the underlying ghostscript drivers. There are
hundreds of them.
Comment 6 Chuck Mead 2001-08-13 09:29:49 EDT
http://www.moongroup.com/images.d/printconf-error.png
printconf-gui crashes and is inoperable

Running roswell beta (the first release). Trying to configure a printer fails
and running it breaks printers which were properly configured and functional
under previous installs. The problem is that there are numerous Python errors,
some which are fatal, and some which simply block continuing to try and
configure. Trond suggested I nab the latest from rawhide and install them. I
did, along with the latest version of Newt and alchemist (both of which were
required to upgrade). No joy... the link above gives a screenshot of the error
message which occurs on start-up. So printconf will not run.

1. Install roswell
2. Try to configure printer.
3. Doesn't work and will break existing configuration if it exists.
4. Install alchemist, newt, printconf, and printconf-gui from rawhide.
(Versions: alchemist-1.0.14-1.i386.rpm, alchemist-devel-1.0.14-1.i386.rpm,
newt-0.50.30-1.i386.rpm, newt-devel-0.50.30-1.i386.rpm,
printconf-0.3.10-1.i386.rpm, printconf-gui-0.3.10-1.i386.rpm)
5. Crashes on startup (see
http://www.moongroup.com/images.d/printconf-error.png)

[root@stealth root]# rpm -Uvh printconf-0.3.10-1.i386.rpm
printconf-gui-0.3.10-1.i386.rpm
Preparing...                ########################################### [100%]
   1:printconf              warning:
/etc/alchemist/namespace/printconf/local.adl created as
/etc/alchemist/namespace/printconf/local.adl.rpmnew
########################################### [ 50%]
warning:    erase rmdir of /var/cache/alchemist/printconf failed: Directory not
empty
warning:    erase rmdir of /usr/share/printconf/util failed: Directory not empty
warning:    erase rmdir of /usr/share/printconf/tests failed: Directory not
empty
warning:    erase rmdir of /usr/share/printconf/mf_rules failed: Directory not
empty
warning:    erase rmdir of /usr/share/printconf failed: Directory not empty
   2:printconf-gui          ########################################### [100%]
[root@stealth root]# printconf-gui 
Traceback (innermost last):
  File "/usr/sbin/printconf-gui", line 7, in ?
    import printconf_gui
  File "/usr/share/printconf/util/printconf_gui.py", line 1895, in ?
    gtk.mainloop()
  File "/usr/share/printconf/util/printconf_conf.py", line 416, in
init_queue_edit
    dict = editor.editReadBox(editbox)
  File "/usr/lib/python1.5/site-packages/pyalchemist_python.py", line 70, in
editReadBox
    depth = editpos)
KeyError: No handler found for box_type: "fileblackbox"

Install printconf and printconf-gui from RH7.1 and it works.
(Versions: printconf-0.2.12-1.i386.rpm and printconf-gui-0.2.12-1.i386.rpm)
Comment 7 Crutcher Dunnavant 2001-08-13 14:46:46 EDT
#6 is fixed.

The fileblackbox problem is an alchemist bug. Upgrade to the latest version of
the alchemist.
Comment 8 Robert L. Cochran Jr. 2001-08-16 20:15:23 EDT
The Help button for printconf-gui (the original Roswell version) does not work 
when clicked. May I ask where I can find corrected packages for the errors 
listed above? I'm trying to get printconf to work myself (using a network print 
server.) Thanks, Bob Cochran.

Note You need to log in before you can comment on or make changes to this bug.