Bug 511320 - Links for QT libraries gets changed from what the RPM packages specifies
Links for QT libraries gets changed from what the RPM packages specifies
Status: CLOSED DUPLICATE of bug 510246
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-14 13:02 EDT by Göran Uddeborg
Modified: 2009-07-15 14:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 23:07:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2009-07-14 13:02:21 EDT
Description of problem:
After upgrading qt, qt-x11, and dependencies, the links ending in .4 points to the file without any suffix.  The RPM package says it should point to the one with 4.5.1 suffix.

Version-Release number of selected component (if applicable):
qt-4.5.1-13.fc11.x86_64
qt-x11-4.5.1-13.fc11.x86_64
qt-devel-4.5.1-13.fc11.x86_64

Steps to Reproduce:
1. yum upgrade qt
2. rpm -V qt qt-x11
  
Actual results:
....L....    /usr/lib64/libQtCore.so.4
....L....    /usr/lib64/libQtDBus.so.4
....L....    /usr/lib64/libQtNetwork.so.4
....L....    /usr/lib64/libQtScript.so.4
....L....    /usr/lib64/libQtSql.so.4
....L....    /usr/lib64/libQtTest.so.4
....L....    /usr/lib64/libQtXml.so.4
....L....    /usr/lib64/libQtXmlPatterns.so.4
....L....    /usr/lib64/libQt3Support.so.4
....L....    /usr/lib64/libQtAssistantClient.so.4
....L....    /usr/lib64/libQtCLucene.so.4
....L....    /usr/lib64/libQtDesigner.so.4
....L....    /usr/lib64/libQtDesignerComponents.so.4
....L....    /usr/lib64/libQtGui.so.4
....L....    /usr/lib64/libQtHelp.so.4
....L....    /usr/lib64/libQtOpenGL.so.4
....L....    /usr/lib64/libQtSvg.so.4
....L....    /usr/lib64/libQtWebKit.so.4


Expected results:
No output should be generated.

Additional info:
Taking the first file as an example, the link actually points like this:

mimmi$ ll /usr/lib64/libQtCore.so.4
lrwxrwxrwx 1 root root 18 14 jul 18.40 /usr/lib64/libQtCore.so.4 -> libQtCore_debug.so

But the RPM package specifies it like this:

mimmi$ rpm -qvl qt | grep libQtCore.so.4
lrwxrwxrwx    1 root    root                       18 maj 30 20:25 /usr/lib64/libQtCore.so.4 -> libQtCore.so.4.5.1
lrwxrwxrwx    1 root    root                       18 maj 30 20:25 /usr/lib64/libQtCore.so.4.5 -> libQtCore.so.4.5.1
-rwxr-xr-x    1 root    root                  2295136 maj 30 20:26 /usr/lib64/libQtCore.so.4.5.1
Comment 1 Rex Dieter 2009-07-14 23:07:22 EDT
Something is broken for you alright, but it's not qt packaging at fault.  (rpm?)
Comment 2 Rex Dieter 2009-07-14 23:07:57 EDT

*** This bug has been marked as a duplicate of bug 510246 ***
Comment 3 Göran Uddeborg 2009-07-15 14:34:27 EDT
(In reply to comment #1)
> Something is broken for you alright, but it's not qt packaging at fault. 
> (rpm?)  

I've seen this happen a number of times previously, and repaired it manually.  It has always been the qt and qt-x11 packages, so it got to be SOMETHING which is special to these packages.

But I do not know what.  I tried a few things, like reinstalling the packages in the transaction when I triggered this now, with and without removing them first. But I could not reproduce the problem.

If I find a reason or a way to reproduce it, I'll add comments to bug 510246.

Note You need to log in before you can comment on or make changes to this bug.