Bug 511324 - exchange calendars cannot be deleted
exchange calendars cannot be deleted
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution-connector (Show other bugs)
5.3
All Linux
high Severity medium
: rc
: ---
Assigned To: Matthew Barnes
desktop-bugs@redhat.com
:
Depends On:
Blocks: 590060 743405 1002709
  Show dependency treegraph
 
Reported: 2009-07-14 13:13 EDT by Jeff Bastian
Modified: 2013-10-06 21:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-06 21:34:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Bastian 2009-07-14 13:13:01 EDT
Description of problem:
If you subscribe to a calendar shared by someone else in Exchange, Evolution shows both Delete and Unsubscribe in the right-click context menu on the calendar.  If you choose Delete, Evolution warns that the calendar will be deleted permanently, but if you then click okay, it doesn't do anything: the calendar is still in the list.  Unsubscribing, however, works fine: it removes the calendar from the list.

In fact, Evolution occasionally pops up a Bug Buddy when I attempt to delete the subscribed-to calendar.

If Evolution cannot delete the calendar, the Delete option should be removed or grayed out from the menu.


Version-Release number of selected component (if applicable):
evolution-2.12.3-8.el5_2.3
evolution-connector-2.12.3-4.el5_2.1
evolution-data-server-1.12.3-6.el5_2.3

How reproducible:
every time

Steps to Reproduce:
1. Create two users on the Exchange server (Exchange 2003 in my testing)
2. Login with Outlook as the first user and create a new calendar.
3. Modify the Sharing Permissions on the new calendar so that it is Folder
   Visible to everyone, and make the second user an Editor
4. Login as the second user with Evolution
5. File -> Subscribe to Other User's Calendar and enter the information for
   the first user's calendar
6. Right click on the newly subscribed-to calendar and choose Delete
  
Actual results:
Evolution either does nothing (best case), or it crashes (worst case)

Expected results:
Delete is removed or grayed out from the menu

Additional info:
Comment 5 RHEL Product and Program Management 2010-08-09 15:38:32 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2011-05-31 11:12:06 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 10 RHEL Product and Program Management 2012-06-11 21:27:32 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 12 Andrius Benokraitis 2013-10-06 21:34:52 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 5, and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.

Note You need to log in before you can comment on or make changes to this bug.