Bug 51133 - lpr: textfiles will not print to a postscript printer due to bug in mf.cfg from printtool-gui
Summary: lpr: textfiles will not print to a postscript printer due to bug in mf.cfg fr...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-07 19:22 UTC by Maurik Holtrop
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-07 20:17:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Maurik Holtrop 2001-08-07 19:22:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2smp i686)

Description of problem:
when a postscript printer is set up using the printtool-gui, it will not
print a plain text file.
The file mf.cfg created by printtool-gui contains an incorrect line for the
TEXTfilter. Replacing this line with:
define(TEXTfilter, `filter enscript -G --header=|%m:%n|  ' )dnl
solves the problem nicely, but it gets overwritten next time printtool-gui
is used.
How do I fix this in printtool-gui?

How reproducible:
Always

Steps to Reproduce:
1. Configure postscript printer using printtoo-gui
2. cat /proc/cpuinfo | lpr -P mypsprinter
3. No output appears.
	

Actual Results:  Nothing.

Expected Results:  A single page on the printer with my CPU info.

Additional info:

The /var/spool/lpd/mypsprinter/mf.cfg file contains an incorrect line
caused by printtool-gui.

Comment 1 Maurik Holtrop 2001-08-07 19:26:16 UTC
Err, that shoud be "printconf-gui" or "printtool", obviously "printtool-gui"
does not exist

Comment 2 Maurik Holtrop 2001-08-07 20:17:15 UTC
I traced the error to /usr/share/printconf/util/make_mfomatic_cfg.pl  line: 141

If I replace:
$text_filter = $foodata->{'ascii'} ? ($chardata->{'cmd'} || 'text "" \r\n\14 ')
: "pipe/postscript/ $enscript_cmd";
with:
$text_filter = "pipe/postscript/ $enscript_cmd";

everything works.

Comment 3 Crutcher Dunnavant 2001-08-22 22:05:18 UTC
got it.


Note You need to log in before you can comment on or make changes to this bug.