Bug 511343 - Changing Architectures of the RHEV-M Related Channels
Changing Architectures of the RHEV-M Related Channels
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Rel-Eng (Show other bugs)
RHN Stable
All Linux
high Severity medium
: ---
: ---
Assigned To: Grant Gainey
Red Hat Network Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-14 15:08 EDT by Jay Greguske
Modified: 2009-07-23 15:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-23 15:32:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Greguske 2009-07-14 15:08:59 EDT
RHN channels related to the RHEV-M product have an incorrect architecture: they are listed as x86_64 but it should be IA-32/i386. The architecture field has been changed to correct this, however the arch is also present in the channel labels (and their corresponding families) which is inconsistent.

The channel labels that need to change are:
rhev-x86_64-m-d-2 ---> rhev-i386-m-d-2
rhev-x86_64-m-s-2 ---> rhev-i386-m-s-2

and the family labels that need to change are exactly the same:
rhev-x86_64-m-d-2 ---> rhev-i386-m-d-2
rhev-x86_64-m-s-2 ---> rhev-i386-m-s-2

These changes need to be replicated in stage and prod environments too. The beta channels should NOT be impacted.
Comment 1 Grant Gainey 2009-07-14 15:20:43 EDT
update rhn.rhnchannel c
   set c.label = 'rhev-i386-m-d-2'
 where c.label = 'rhev-x86_64-m-d-2';
 
update rhn.rhnchannel c
   set c.label = 'rhev-i386-m-s-2'
 where c.label = 'rhev-x86_64-m-s-2';
 
update rhn.rhnchannelfamily cf
   set cf.label = 'rhev-i386-m-d-2'
 where cf.label = 'rhev-x86_64-m-d-2';
 
update rhn.rhnchannelfamily cf
   set cf.label = 'rhev-i386-m-s-2'
 where cf.label = 'rhev-x86_64-m-s-2';
Comment 2 Grant Gainey 2009-07-14 15:33:38 EDT
This change can't be accomplished using the RCM tooling, because the channel/family label is the *id* those tools work with.  Therefore, it must be done with SQL run against the DB.

The above SQL is checked in here:

http://git.corp.redhat.com/?p=rhn/rhn.git;a=blob;f=schema/changes/dev/512/511343.sql;h=1b8a68619c8fa590ce6c3b1420cc08c3cb752e63;hb=HEAD

It needs to be run in STAGE and PROD
Comment 3 Denise Hughes 2009-07-23 15:32:38 EDT
This is complete and stage and prod.  Closing bug.

Note You need to log in before you can comment on or make changes to this bug.