Bug 511360 - suggestion to change default 'configdir' value
suggestion to change default 'configdir' value
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kismet (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-14 15:58 EDT by Christoph A.
Modified: 2009-09-13 07:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-13 07:54:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph A. 2009-07-14 15:58:48 EDT
Description of problem:
The default 'configdir' value in kismet.conf violates the SELinux Policy which denies access to $HOME for kismet - which is actually good.

I changed the value of configdir from '%h' to '/var/lib/kismet/' and it works fine.

Version-Release number of selected component (if applicable):
rpm -qa kismet
kismet-0.0.2008.05.R1-5.fc11.i586

How reproducible:
allways


Steps to Reproduce:
1. install kismet
2. change source config line in kismet.conf
3. make sure you are using a recent selinux policy >=3.6.12-64.f11
4. start kismet
5. see SELinux AVCs
  
Actual results:
kismet tries to access files in $HOME - which is denied by SELinux

Expected results:
kismet should not access files in $HOME.

Additional info:
Changing the default 'configdir' value (line 373 in kismet.conf) from '%h' to '/var/lib/kismet/' as suggested by Dan [1] would increase user experience and maintain the security enforced by SELinux (preventing access to $HOME).

[1] https://fcp.surfsite.org/modules/newbb/viewtopic.php?viewmode=threaded&order=DESC&topic_id=63791&forum=10&move=prev&topic_time=1226501702

For reference: https://bugzilla.redhat.com/show_bug.cgi?id=509756

How do you think about this suggestion?
Comment 1 Enrico Scholz 2009-09-13 07:54:00 EDT
It's a good idea but because 2009.06.R1 (in rawhide) works completely different regarding these things, I won't apply this change (which might break existing setups).  Thanks for your suggestions/

Note You need to log in before you can comment on or make changes to this bug.