Bug 511399 - The dcb adminstrative tools are not included in the RH6 Alpha disc images.
The dcb adminstrative tools are not included in the RH6 Alpha disc images.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: distribution (Show other bugs)
6.0
All Linux
high Severity high
: alpha
: ---
Assigned To: RHEL Product and Program Management
qe-baseos-daemons
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-14 18:54 EDT by Aaron Brown
Modified: 2014-01-21 01:14 EST (History)
12 users (show)

See Also:
Fixed In Version: lldpad-0.9.38-3.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:15:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Brown 2009-07-14 18:54:54 EDT
Description of problem:
Checked both the i386 and x86_64 variants of the DVD and CD Red Hat 6.0 Alpha
images as well as the source CD images and no package for the dcb
administrative tools is included.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Extract CD images or burn CDs and search for dcb, or set up installation
repository and try to install dcbd

Actual results:
No package is found.

Expected results:
Package found and installation attempt installs package.

Additional info:
Selected yum as a "closest guess" as there is no listing for the dcbd
component and I can not install the user tool via yum.  The component really
should be dcbd.
Comment 2 Aaron Brown 2009-07-14 19:14:20 EDT
Adding zeleny@redhat.com, the package maintainer for this component in Rawhide and Intel developers robert.w.love@intel.com, yi.zoue@intel.com
Comment 3 Aaron Brown 2009-07-14 19:17:33 EDT
Yi Zou does not have a Red Hat Bugzilla account yet so my attempt to add him was rejected (and I misspelled it in the above comment, it should be yi.zou@intel.com
Comment 4 RHEL Product and Program Management 2009-07-14 19:17:59 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Aaron Brown 2009-07-14 19:22:36 EDT
Changing owner to Jan Zeleny, the maintainer for this package under Fedora 11 and Rawhide.
Comment 6 Bill Nottingham 2009-07-15 21:34:51 EDT
Should be fixed in Alpha 2.
Comment 7 Martin George 2009-10-27 09:49:26 EDT
I see fcoe-utils included in RHEL 5.4 GA, but not the dcb package. Is this planned for RHEL 5.4?
Comment 8 Jan Zeleny 2009-10-27 10:26:06 EDT
No. The dcbd package depends on kernel 2.6.29 and higher, which is not included in RHEL 5.4 AFAIK.
Comment 9 Eric Multanen 2009-10-27 14:58:37 EDT
The dcbd package will be in RHEL 6 alpha 2 - correct?

Also, Jan is correct about the dcbd package and RHEL 5.4.
Comment 10 John Villalovos 2009-10-27 15:44:41 EDT
RHEL 6 Alpha 2 was released today.  Can you recheck?
Comment 11 Suzanne Yeghiayan 2009-10-30 17:25:13 EDT
dcbd-0.9.15-3.el6 was included in Alpha 2.
Comment 12 releng-rhel@redhat.com 2009-10-30 18:10:33 EDT
Fixed in 'dcbd-0.9.15-3.el6', included in compose 'RHEL6.0-20091029.0'.
Moving to ON_QA.
Comment 13 Aaron Brown 2009-11-12 21:35:56 EST
The Red Hat 6 Alpha2 release does have FCoE, dcbd and other dependencies included with the install media.  This was confirmed with both x86 and x86_64 architectures.  Versions are:
# dcbd -v
dcbd v0.9.15
Copyright (c) 2007-2009, Intel Corporation

Portions used and/or modified from:  hostapd v 0.5.7
Copyright (c) 2004-2007, Jouni Malinen <j@w1.fi> and contributors

# fcoeadm -v
fcoeadm v1.0.7
Copyright (c) 2009, Intel Corporation.

Note:  These are appropriate versions for the 2.6.31-27.el6.2 kernel that is included with the Alpha2, but they will need to be revved if / when the kernel jumps to a 2.6.32 or alter version.
Comment 14 Alexander Todorov 2010-08-20 14:14:05 EDT
In snap #12  - 0818.0 

fcoeadm is included in fcoe-utils package but there's no dcbd package or command available. Moving back to ASSIGNED.
Comment 15 Eric Multanen 2010-08-20 14:24:35 EDT
The lldpad package replaced the dcbd package.
Comment 16 Alexander Todorov 2010-08-21 07:10:58 EDT
lldpad-0.9.38-3.el6 is available in snap #12. 

# rpm -q lldpad -l
/etc/rc.d/init.d/lldpad
/usr/sbin/dcbtool
/usr/sbin/lldpad
/usr/sbin/lldptool
/usr/share/doc/lldpad-0.9.38
/usr/share/doc/lldpad-0.9.38/COPYING
/usr/share/doc/lldpad-0.9.38/ChangeLog
/usr/share/doc/lldpad-0.9.38/README
/usr/share/man/man8/dcbtool.8.gz
/usr/share/man/man8/lldpad.8.gz
/usr/share/man/man8/lldptool.8.gz
/var/lib/lldpad


# dcbtool -v
dcbtool v0.9.38
Copyright (c) 2007-2010, Intel Corporation

Substantially modified from:  hostapd_cli v 0.5.7
Copyright (c) 2004-2007, Jouni Malinen <j@w1.fi> and contributors


Moving to VERIFIED.
Comment 17 releng-rhel@redhat.com 2010-11-10 15:15:01 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.