Bug 511400 - Header Include Bug in SystemPerl
Header Include Bug in SystemPerl
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-SystemPerl (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-14 19:10 EDT by Lane
Modified: 2009-07-19 06:13 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.330-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-19 06:13:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lane 2009-07-14 19:10:59 EDT
Description of problem:
There is a header include bug in the current release of system perl that causes verilator problems.  See full description at http://www.veripool.org/issues/100.
This is a blocker to releasing the verilator rpm as it completely breaks verilator when trying to simulate with tracing enabled.

Version-Release number of selected component (if applicable):
perl-SystemPerl-1.321-1.fc10.i386

How reproducible:
Try verilating a design with tracing enabled.  Fails on undefined type due to a bug in the system perl header files.  

Additional info:
Wilson has fixed this in the git version of system perl.  So we either need Wilson to do another release or apply the patch from the latest git version.
Comment 1 Chitlesh GOORAH 2009-07-15 05:57:03 EDT
Can you try this scratch build of SystemPerl (based on latest git) ?

https://koji.fedoraproject.org/scratch/chitlesh/task_1475116/
Comment 2 wsnyder 2009-07-15 07:23:38 EDT
I also just pushed a new version 1.330 to CPAN so you should be able to fetch it as normal.  It may take a few hours to be downloadable.
Comment 3 Fedora Update System 2009-07-15 08:40:23 EDT
perl-SystemPerl-1.330-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/perl-SystemPerl-1.330-1.fc11
Comment 4 Fedora Update System 2009-07-19 06:13:35 EDT
perl-SystemPerl-1.330-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.