Bug 511401 - Most peak-rules directives throw DeprecationWarning under python >= 2.6
Summary: Most peak-rules directives throw DeprecationWarning under python >= 2.6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-peak-rules
Version: 11
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kyle VanderBeek
QA Contact: Fedora Extras Quality Assurance
URL: http://www.eby-sarna.com/pipermail/pe...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-07-14 23:26 UTC by Kyle VanderBeek
Modified: 2009-07-29 21:31 UTC (History)
2 users (show)

Fixed In Version: 0.5a1.dev-8.2582.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-07-29 21:31:05 UTC


Attachments (Terms of Use)

Description Kyle VanderBeek 2009-07-14 23:26:46 UTC
Description of problem:
Due to some fancy footwork inside peak-rules, many directives throw a DeprecationWarning due to the way python >= 2.6 has deprecated sending any additional arguments to object.__new__(cls).

I'm discussing this with PEAK people right now, thread URL above.  The resulting fix is likely a patch to python-peak-util-addons, but I'm doing this to help me keep track of it.

It's causing deprecation warnings with Pylons under 2.6.


Version-Release number of selected component (if applicable):
python-peak-rules-0.5a1.dev-5.2582

How reproducible:
Always.

Steps to Reproduce:
#!/usr/bin/python

from peak.rules import before

def foo():
    print "foo"

@before(foo, "True")
def bar():
    print "bar"

foo()

Actual results:
/usr/lib/python2.6/site-packages/peak/rules/indexing.py:220: DeprecationWarning: object.__new__() takes no parameters
        return super(BitmapIndex, cls).__new__(cls, engine, expr)
bar
foo

Expected results:
bar
foo

Comment 1 Fedora Update System 2009-07-15 05:29:43 UTC
python-peak-rules-0.5a1.dev-8.2582.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/python-peak-rules-0.5a1.dev-8.2582.fc11

Comment 2 Fedora Update System 2009-07-19 10:36:07 UTC
python-peak-rules-0.5a1.dev-8.2582.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-peak-rules'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7792

Comment 3 Fedora Update System 2009-07-29 21:31:00 UTC
python-peak-rules-0.5a1.dev-8.2582.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.