Bug 51170 - Pound sign invisible in gnome-terminal
Pound sign invisible in gnome-terminal
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-core (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Mason
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-07 20:32 EDT by adam.huffman
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-07 20:32:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
results of pressing shift-1234567890 x3 in gnome-terminal (30.48 KB, image/jpeg)
2001-08-08 18:43 EDT, adam.huffman
no flags Details
results of pressing shift-1234567890 x3 in xterm (14.04 KB, image/jpeg)
2001-08-08 18:44 EDT, adam.huffman
no flags Details

  None (edit)
Description adam.huffman 2001-08-07 20:32:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010725

Description of problem:
The pound sign is not visible when shift-3 is pressed in gnome-terminal,
although the cursor does move one place to the right.
It is visible when the key is pressed in a normal xterm.

How reproducible:
Always

Steps to Reproduce:
1. login
2. open a gnome-terminal
3. press shift-3
	

Actual Results:  cursor moved one place to the right but with no visible
character

Expected Results:  a pound sign should have been printed

Additional info:

LANG is set to en_GB
Comment 1 David Mason 2001-08-08 10:30:12 EDT
works on every beta install I can find
Comment 2 adam.huffman 2001-08-08 18:43:24 EDT
Created attachment 26915 [details]
results of pressing shift-1234567890 x3 in gnome-terminal
Comment 3 adam.huffman 2001-08-08 18:44:54 EDT
Created attachment 26916 [details]
results of pressing shift-1234567890 x3 in xterm
Comment 4 David Mason 2001-08-09 10:07:40 EDT
With others looking on in amazement at your screenshots the first thing that
came to mind is that you have a broken keyboard. Does this happen in a virtual
console as well? (CTRL-ALT-F1)
Comment 5 adam.huffman 2001-08-09 20:12:34 EDT
No, there's no problem on the console or in the seawolf installation on the same
 box.

Just tried changing between runlevels 5 and 3, and there is no such problem
in runlevel 3, so it seems to be caused by gdm.  There are actually some other
problems with my gdm setup on this installation e.g. the aliases, colour ls etc. 
are not being sourced.
Comment 6 Need Real Name 2003-04-27 13:46:49 EDT
In Red Hat 9:

Typing shift-3 (the British pound sign) in gnome-terminal does not give me a
pound sign - instead I get a strange looking "t" character.

It looks like a line drawing of a t.

When I paste it here I *do* get a pound sign: £
The pound sign appears fine when I use the console.

Note You need to log in before you can comment on or make changes to this bug.