Bug 51172 - Alt/Meta bindings problem in Gnome
Summary: Alt/Meta bindings problem in Gnome
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: sawfish   
(Show other bugs)
Version: roswell
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 54904 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-08 00:45 UTC by adam.huffman
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-09 23:28:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description adam.huffman 2001-08-08 00:45:05 UTC
Description of Problem:
The bindings set up for sawfish by default do not work e.g.
Activating the various workspaces, cycling windows, sending a window to the
next workspace etc.

How Reproducible:
every time

Steps to Reproduce:
1. start a gnome session
2. try to cycle open windows, or activate a new workspace
3. 

Actual Results:
either nothing happens, or e.g. a tab is captured instead of alt-tab

Expected Results:
The bindings as listed in the sawfish configuration tool should work

Additional Information:

Comment 1 David Mason 2001-08-08 14:31:25 UTC
hp... this works for me - however could this be that odd changing of meta keys
we saw before?

Comment 2 Havoc Pennington 2001-08-08 16:10:59 UTC
What is your keymap like?

Open "xev", type the Alt and Windows keys into it, paste in the output it has
for KeyPress event.

Is this a fresh install?

Comment 3 adam.huffman 2001-08-08 22:24:04 UTC
Here is the xev output:

KeyPress event, serial 28, synthetic NO, window 0x2000001,
    root 0x32, subw 0x0, time 877267693, (788,362), root:(817,424),
    state 0x0, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 characters:  ""

KeyRelease event, serial 28, synthetic NO, window 0x2000001,
    root 0x32, subw 0x0, time 877267802, (788,362), root:(817,424),
    state 0x8, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 characters:  ""

KeyPress event, serial 28, synthetic NO, window 0x2000001,
    root 0x32, subw 0x0, time 877271248, (788,362), root:(817,424),
    state 0x0, keycode 115 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 characters:  ""

KeyRelease event, serial 28, synthetic NO, window 0x2000001,
    root 0x32, subw 0x0, time 877271333, (788,362), root:(817,424),
    state 0x40, keycode 115 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 characters:  ""


This is from a new installation.

Comment 4 Havoc Pennington 2001-08-09 23:28:17 UTC
Thanks, I have no initial idea here. It has happened to a couple other people; I
was hoping xev output would help :-( will try to investigate further.

Comment 5 Havoc Pennington 2002-03-01 15:24:23 UTC
I don't know how to reproduce this; moving to GNOME 2 soon so only critical 
fixes are going in to GNOME 1.x stuff.

Possibly related to #54491 but I don't think it is the same bug.

Comment 6 Havoc Pennington 2002-03-01 15:27:13 UTC
*** Bug 54904 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.