Bug 51192 - autopartitioning leaves empty space when 2 disks present
autopartitioning leaves empty space when 2 disks present
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-08 08:20 EDT by Patrick C. F. Ernzer
Modified: 2008-01-17 12:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick C. F. Ernzer 2001-08-08 08:20:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010803

Description of problem:
When choosing automatic partitioning during installation on a system with 2
disks, /boot ans swap are put onto the first disk, leaving most of it free.
/ occupies all of the second disk.

How reproducible:
Always

Steps to Reproduce:
1. Have 2 discs in the machine
2. Select automatic partitioning during install

	

Actual Results:  most of disc 1 is left unassigned

Expected Results:  usage of all available disc space. maybe use it for
/home? or not use disc 2 at all so that the user can do with it what she/he
wants.

Additional info:

/dev/hda:

 Model=WDC WD100BB-75AUA1, FwRev=18.20D18, SerialNo=WD-WMA6Z1142400
 Config={ HardSect NotMFM HdSw>15uSec SpinMotCtl Fixed DTR>5Mbs FmtGapReq }
 RawCHS=16383/16/63, TrkSize=57600, SectSize=600, ECCbytes=40
 BuffType=DualPortCache, BuffSize=2048kB, MaxMultSect=16, MultSect=16
 CurCHS=16383/16/63, CurSects=-66060037, LBA=yes, LBAsects=19541088
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes: pio0 pio1 pio2 pio3 pio4 
 DMA modes: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 *udma4 udma5 
 AdvancedPM=no
 Drive Supports : Reserved : ATA-1 ATA-2 ATA-3 ATA-4 ATA-5 


/dev/hdb:

 Model=WDC WD100BB-75AUA1, FwRev=18.20D18, SerialNo=WD-WMA6Z1142397
 Config={ HardSect NotMFM HdSw>15uSec SpinMotCtl Fixed DTR>5Mbs FmtGapReq }
 RawCHS=16383/16/63, TrkSize=57600, SectSize=600, ECCbytes=40
 BuffType=DualPortCache, BuffSize=2048kB, MaxMultSect=16, MultSect=16
 CurCHS=16383/16/63, CurSects=-66060037, LBA=yes, LBAsects=19541088
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes: pio0 pio1 pio2 pio3 pio4 
 DMA modes: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 *udma4 udma5 
 AdvancedPM=no
 Drive Supports : Reserved : ATA-1 ATA-2 ATA-3 ATA-4 ATA-5 


Disk /dev/hda: 255 heads, 63 sectors, 1216 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1         6     48163+  83  Linux
/dev/hda2             7        39    265072+  82  Linux swap

Disk /dev/hdb: 255 heads, 63 sectors, 1216 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdb1   *         1      1216   9767488+  83  Linux
Comment 1 Glen Foster 2001-08-08 15:13:06 EDT
We (Red Hat) should try to fix this before next release.
Comment 2 Michael Fulbright 2001-08-08 21:57:22 EDT
This is the behavior which has been present since at least 6.1.  The
autopartitioning algorithm will be revisited for the next release.  For now you
can choose to review the autopartitioning results and then restrict the
partitions to the drive you want. Alternately you can tell autopartitioning to
only use one drive.

Comment 3 Michael Fulbright 2002-03-26 12:45:42 EST
Deferring to future release.
Comment 4 Red Hat Bugzilla 2006-02-21 13:48:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.