Bug 51219 - vfs: cannot open root device "" or 08:41
vfs: cannot open root device "" or 08:41
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-08 11:43 EDT by wrest
Modified: 2007-03-26 23:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-28 21:27:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wrest 2001-08-08 11:43:16 EDT
Description of Problem:

i try to install redhat 7.1 on a compaq proliant 2500 server

when i boot the install cd the kernel stops with:

NET4: Unix Domain sockets 1.0/SMP for Linux NET4.0
VFS: Cannot open root device "" or 08:41
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 08:41


How Reproducible:

Steps to Reproduce:
1. insert RH 7.1 CD in Proliant 2500 Server and turn power on
2. enter the boot option linux mem=1024M (your ram size)
   (normaly Linux only find 16MB RAM in the Proliant if you dont specify
    the correct size)
3. watch the kernel booting and you will get this error.

Actual Results:

i installed RH7.0 and Mandrake 8.0 on this Server,
all works fine.. only get this error with RH7.1

Proliant 2500 Config:

2 Pentium Pro 200Mhz CPU4S
1024 MB RAM = 4 256MB RAM Compaq Modules
5 Compaq HD 4,3GB on a Compaq Smart Array Controller

also the system was running since 4 years with NT4.0 Server
all day and night.. hmm... :)))) *no lie*

but now it needs RH7.1 .. not WIN2K

best regards

Expected Results:


Additional Information:
Comment 1 Brent Fox 2001-08-09 23:21:56 EDT
Can you try booting with 'linux ide=nodma' at the boot screen?  Does that help?
Comment 2 wrest 2001-08-10 10:11:18 EDT
the same problem with "ide=nodma"

the harddisks are on a compaq smart 2DH controller - in a RAID5

i installed suse 7.2 today.. works fine on this system
Comment 3 Brent Fox 2001-08-10 12:11:48 EDT
This looks like a kernel problem.  Changing component.
Comment 4 Arjan van de Ven 2001-08-10 12:57:18 EDT
Can you please try the following options?

"mem=exactmap mem=640k@0 mem=255@1M"

Comment 5 Johannes Dharmawan 2001-08-15 16:01:37 EDT
Hi,
I'm having the same problem when I try to install Red Hat Linux 7.1 into Toshiba Portege 7000CT. 
I used DOS to run the installer (from CD ROM) and got the same error msg: VFS: cannot open root device "" or 08:41

How do try the suggestion above by arjanv: 
Can you please try the following options? "mem=exactmap mem=640k@0 mem=255@1M" 
Does this relate to me.
--johannes
Comment 6 Need Real Name 2002-03-03 21:03:04 EST
I'm having the same problem with installing RH7.1 on my P-120 64MB Midwest Micro
PC. Tried the above solutions to no avail.  JJOLEARY@OPTONLINE.NET

VFS: cannot open root device "" or 8:41
Comment 7 Mike Harpe 2002-10-28 19:21:54 EST
Hello,

I have the exact same problem here as well. Installing 7.2 

I tried the mem options listed previously but my system starts to load and then
goes to blank screen and nothing. I am a Linux newbe ( sorry)...  I didn't open
a web support ticket, do I need to since this is already being worked on?

My system is asus p2bs with aic7876 onboard. IBM 9Gig HDD ( 1111 sectors if it
matters, I get warning messages) 254meg ram. What other information would you like?

I know windows OS well, but I am sucking my thumb here guys...
Comment 8 Mike Harpe 2002-10-28 21:26:59 EST
Hey,
I don't know if this matters but
 I noticed the error indicated here is happening when the install cd is booted.
I make it all the way through the install and get the error "vfs: cannot open
root device "sda2" or 08:02 "when Linux tries to load from my scsi drive. 

Mike
Comment 9 wrest 2002-10-29 10:07:28 EST
"mem=exactmap mem=640k@0 mem=255@1M"

works for me.. sorry for the late answer ;)

here is my working grub.conf, rh7.3 runs good on this old compaq proliant 2500

best regards
 
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/ida/c0d0p3
#          initrd /initrd-version.img
#boot=/dev/ida/c0d0
default=0
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
title Red Hat Linux (2.4.18-17.7.xsmp)
root (hd0,0)
kernel /vmlinuz-2.4.18-17.7.xsmp ro root=/dev/ida/c0d0p3 mem=exactmap 
mem=640K@0 mem=511M@1M
initrd /initrd-2.4.18-17.7.xsmp.img
title Red Hat Linux (2.4.18-17.7.x)
root (hd0,0)
kernel /vmlinuz-2.4.18-17.7.x ro root=/dev/ida/c0d0p3 mem=exactmap mem=640K@0 
mem=511M@1M
initrd /initrd-2.4.18-17.7.x.img
title Red Hat Linux (2.4.18-10smp)
root (hd0,0)
kernel /vmlinuz-2.4.18-10smp ro root=/dev/ida/c0d0p3 mem=exactmap mem=640K@0 
mem=511M@1M
initrd /initrd-2.4.18-10smp.img
title Red Hat Linux (2.4.18-10)
root (hd0,0)
kernel /vmlinuz-2.4.18-10 ro root=/dev/ida/c0d0p3 mem=exactmap mem=640K@0 
mem=511M@1M
initrd /initrd-2.4.18-10.img
title Red Hat Linux (2.4.18-5smp)
root (hd0,0)
kernel /vmlinuz-2.4.18-5smp ro root=/dev/ida/c0d0p3 mem=exactmap mem=640K@0 
mem=511M@1M
initrd /initrd-2.4.18-5smp.img
title Red Hat Linux (2.4.18-5)
root (hd0,0)
kernel /vmlinuz-2.4.18-5 ro root=/dev/ida/c0d0p3 mem=exactmap mem=640K@0 
mem=511M@1M
initrd /initrd-2.4.18-5.img

Note You need to log in before you can comment on or make changes to this bug.