Bug 5122 - lpr still does not work on remote printers
lpr still does not work on remote printers
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: lpr (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-13 23:49 EDT by tanner
Modified: 2014-03-16 22:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-17 23:20:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tanner 1999-09-13 23:49:24 EDT
Redhat 6.0
Linux 2.2.7-1.23smp
glib-1.2.1-2
lpr-0.41-1
HP LaserJet 2100 PS

I followed the bug-thread regarding lpr and went and grabbed
the lpr-0.41 SRPMS from rawhide.redhat.com, but I still
looks like lpd dies and/or I cannot print to remote
printers.

Here is my printserver /etc/printcap:

lp|laserjet:\
        :lp=/dev/null:\
        :sd=/var/spool/lpd/lp:\
        :mx#0:\
        :sh:\
        :rm=laserjet:\
        :rp=raw:\
        :if=/var/spool/lpd/lp/filter:

Here is the /etc/printcap on one of the workstations:

lp|laserjet:\
        :sd=/var/spool/lpd/lp:\
        :mx#0:\
        :sh:\
        :rm=printserver.real-time.com:\
        :rp=laserjet:\
        :if=/var/spool/lpd/lp/filter:

printserver% lpq
king: Warning: no daemon present
Rank   Owner      Job  Files
Total Size
1st    tanner     0    thief.qeFdla
2nd    tanner     1    thief.pLWcth
4th    tanner     13    ...
0 bytes

JetDirect lpd: no jobs queued on this port

workstation% lpq
connection to printserver.real-time.com is down

printserver%  ps -aux | grep lpd
root     29874  0.0  0.5  1464  660 lpd -l

It seems to that a lpq kills the remote lpd.

Restarting lpd things work for awhile, then they die again.
Comment 1 ahlbrink 1999-09-14 10:50:59 EDT
rawhide-release 19990907
every used network printer (Tek 380,440,550; HP 4050)
(the /etc/printcap is made by the printtool, it resembles the one
given in the bug report 5122)

Everytime I sent a print job to one of the network printers,
I got: "no daemon present". This job had been printed, the size of the
job then got null. Then I have to "lprm" the job to be able to send a
new job.
Comment 2 Bill Nottingham 1999-09-17 18:33:59 EDT
I can't reproduce this here with lpr-0.41-2. Are you running
it on just the client, or also on the remote server?
Comment 3 Michael K. Johnson 1999-09-20 14:42:59 EDT
This generally happens when one of the remote printers is down
(or no longer exists or generally cannot be contacted) at the
time that lpd is started.  Check to see if this is the case for
any of the remote printers defined in /etc/printcap
Comment 4 trouble 1999-09-29 10:49:59 EDT
Remote printing only works for me with lpr-0.41 on the server and
lpr-0.35-1 on the client. If I put lpr-0.41 on the client, it leaves a
df* file in the server spool dir, but nothing prints. No complaints in
syslog either way.
jweber@math.cudenver.edu
Comment 5 Bill Nottingham 1999-09-29 12:48:59 EDT
What is the df* file's name?

You say that there are no cf* files to correspond to it?
Comment 6 Bill Nottingham 1999-10-08 13:34:59 EDT
OK, could you upgrade to the lpr-0.42-1 RPMs at

ftp://people.redhat.com/notting/lpr/
http://people.redhat.com/notting/lpr/

and then restart lpd? These should work.
Comment 7 Bill Nottingham 1999-10-17 23:20:59 EDT
Should be fixed in the 0.43-2 errata release.

Note You need to log in before you can comment on or make changes to this bug.