Bug 512289 - qemu-kvm process exits when copying files to a virtual machine running fedora 9 GA
qemu-kvm process exits when copying files to a virtual machine running fedora...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 512633 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-17 01:44 EDT by Lucas Meneghel Rodrigues
Modified: 2015-10-18 18:41 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-11 12:46:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lucas Meneghel Rodrigues 2009-07-17 01:44:28 EDT
Description of problem: Using the latest rawhide qemu-kvm packages, it's possible to terminate a qemu-kvm process running a Fedora 9 guest only by copying files to that VM trough scp.

Version-Release number of selected component (if applicable):

[lmr@freedom ~]$ rpm -qa | grep qemu
qemu-debuginfo-0.10.50-11.kvm88.fc11.x86_64
qemu-common-0.10.50-8.kvm87.fc11.x86_64
qemu-system-arm-0.10.50-8.kvm87.fc11.x86_64
qemu-system-sh4-0.10.50-8.kvm87.fc11.x86_64
qemu-system-x86-0.10.50-8.kvm87.fc11.x86_64
qemu-system-ppc-0.10.50-8.kvm87.fc11.x86_64
qemu-img-0.10.50-8.kvm87.fc11.x86_64
qemu-kvm-0.10.50-8.kvm87.fc11.x86_64
qemu-system-cris-0.10.50-8.kvm87.fc11.x86_64
qemu-kvm-tools-0.10.50-8.kvm87.fc11.x86_64
qemu-system-sparc-0.10.50-8.kvm87.fc11.x86_64
qemu-0.10.50-8.kvm87.fc11.x86_64
qemu-user-0.10.50-8.kvm87.fc11.x86_64
qemu-system-m68k-0.10.50-8.kvm87.fc11.x86_64
qemu-system-mips-0.10.50-8.kvm87.fc11.x86_64

How reproducible:

Allways

Steps to Reproduce:
1. Install 2 vms, one with fedora 11 and another one with fedora 9
2. Setup ssh key authentication from the f11 VM into the f9 VM
3. scp a directory from the f11 VM to the f9 VM
  
Actual results:

The VM process running the Fedora 9 guest just ends out of the blue.

Expected results:

The remote copy should just finish, without any of the guests being terminated.

Additional info:

Even after building and installing the debuginfo packages I couldn't get a lot of useful information, I've attached gdb to the qemu running process and reproduced the bug - there's no segfault as I first thought, the program just ends with exit code 01 out of the blue:

{{{
(gdb) c
Continuing.
[Thread 0x7fba565ea910 (LWP 6726) exited]
[New Thread 0x7fba565ea910 (LWP 6758)]
[Thread 0x7fba565ea910 (LWP 6758) exited]
[New Thread 0x7fba565ea910 (LWP 6760)]
[Thread 0x7fba565ea910 (LWP 6760) exited]
[Thread 0x7fba586e6910 (LWP 6693) exited]

Program exited with code 01.
}}}

Dmesg taken during the bug being reproduced shows the following:

{{{
[lmr@freedom ~]$ dmesg
virbr0: port 2(vnet1) entering disabled state
device vnet1 left promiscuous mode
virbr0: port 2(vnet1) entering disabled state
}}}

For /var/log/messages we have:

{{{
Jul 17 02:36:58 localhost avahi-daemon[1824]: Withdrawing address record for fe80::703f:acff:fe56:bd6c on vnet1.
Jul 17 02:36:58 localhost kernel: virbr0: port 2(vnet1) entering disabled state
Jul 17 02:36:58 localhost kernel: device vnet1 left promiscuous mode
Jul 17 02:36:58 localhost kernel: virbr0: port 2(vnet1) entering disabled state
Jul 17 02:37:00 localhost ntpd[2052]: Deleting interface #34 vnet1, fe80::703f:acff:fe56:bd6c#123, interface stats: received=0, sent=0, dropped=0, active_time=1111 secs
}}}

Another info that might be useful is that when we copy files *from* the f9 VM to the f11 VM it takes a little longer to reproduce, but in the end, the f9 VM ends up dying. I suspect of a bug on f9 GA SSH package that is uncovering a very weird qemu-kvm bug, proceeding with the investigation.
Comment 1 Glauber Costa 2009-07-17 14:15:39 EDT
sounds like a kernel bug in virtio-net.
In fact, I tested, and it does not happen with other NICs.

Will test a new kernel and follow up here.
Comment 2 Glauber Costa 2009-07-17 14:29:10 EDT
Verified:
kernel bug, that is fixed in 2.6.29.6-213. Will reassign to kernel and bump it's karma
Comment 3 Glauber Costa 2009-07-20 09:48:08 EDT
*** Bug 512633 has been marked as a duplicate of this bug. ***
Comment 4 Christopher Beland 2010-03-08 12:05:11 EST
kernel-2.6.30.10-105.2.23.fc11 has been released for Fedora 11 stable; can this bug be closed?
Comment 5 Lucas Meneghel Rodrigues 2010-03-08 12:38:13 EST
Yes, this can be closed. Sorry I didn't notice it wasn't closed.

Note You need to log in before you can comment on or make changes to this bug.