Bug 51236 - ps hangs after a crash in Oracle 8.1.6
ps hangs after a crash in Oracle 8.1.6
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: procps (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-08 13:25 EDT by Mauro
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-07 12:51:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mauro 2001-08-08 13:25:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (Win98; U)

Description of problem:
My Oracle 8.1.6 started reporting several erros such  as 
"*** SESSION ID:(26.57) 2001-08-08 10:23:22.798
*** 2001-08-08 10:23:22.798
ksedmp: internal or fatal error
ORA-00600: internal error code, arguments: [2662], [0], [4041544], [1170], [173016221], [14681243], [], []
----- Call Stack Trace -----
calling              call     entry                argument values in hex
location             type     point                (? means dubious value)
-------------------- -------- -------------------- ----------------------------
Cannot seek to string table section header in /lib/libm.so.6.
Cannot seek to string table section header in /lib/libm.so.6.
Cannot seek to string table section header in /lib/libm.so.6.
Cannot seek to string table section header in /lib/libm.so.6.
Cannot read string table section header in /lib/libm.so.6.
ksedmp()+142         CALL     ksedst()+0
ksfdmp()+14          CALL     ksedmp()+0
kgesiv()+234         CALLr    00000000
ksesic5()+95         CALL     kgesiv()+0
kcsgbsn()+266        CALL     ksesic5()+0
kcrfwr()+549         CALL     kcsgbsn()+0          51C57414 ?
kcbchg1()+5263       CALL     kcrfwr()+0
kcbchg()+133         CALL     kcbchg1()+0
ktucmt()+1929        CALL     kcbchg()+0           51DD0880 ? 1 ? 0 ? 1 ?
                                                   80545EE ? BFFFD160 ?
ktcrcm()+1014        CALL     ktucmt()+0           0 ? 0 ? 0 ? 7 ? 51DD0880 ?
                                                   BFFFEFCC ? 0 ? 0 ? 0 ?
kqlwvidl()+332       CALL     ktcrcm()+0           0 ? 0 ? BFFFD3A0 ? BFFFD484 ? "

When I try to figure out the pid pf oracle pmon process with ps fax | grep pmon, ps hangs. The same occurs with the w command and shutdown.

Whenever this kind of error is reported by oracle, ps hangs. It occured twice this week.


How reproducible:
Couldn't Reproduce


Additional info:

Kernel

Linux version 2.4.2-2 (root@pinoquio.uss.UUCP) (gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-81)) #1 SMP 


Processor type

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 6
cpu MHz         : 799.813
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse
bogomips        : 1595.80
Comment 1 Need Real Name 2002-02-07 12:51:15 EST
I am having a simular problem. I am running RH7.1 (Linux  2.4.2-2 ) with oracle 
8.1.7.02. After running the system under load. ps and even ls commands are 
haning. I;ve noted with top that all the available memory of the system (2Gb 
ius  being used) -- yet the oracle sga is only 300 MB. I have spoken with 
oracle tech support and they inist it is an OS bug but won't give further 
details.

top output:
89 processes: 87 sleeping, 2 running, 0 zombie, 0 stopped
CPU0 states:  7.1% user,  3.1% system,  0.0% nice, 88.1% idle
CPU1 states: 12.1% user,  1.1% system,  0.0% nice, 85.1% idle
Mem:  2059092K av, 2056028K used,    3064K free,       0K shrd,    2600K buff
Swap: 1992040K av,       0K used, 1992040K free                 1906296K cached

  PID USER     PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM   TIME COMMAND
 1033 oracle     9   0 55056  53M 53532 S     0.0  2.6  16:50 oracle
 1029 oracle    17   0 54320  53M 52812 R    11.3  2.6  16:10 oracle
 1037 oracle     9   0 54312  53M 52796 S     0.0  2.6  16:47 oracle
 1041 oracle     9   0 54276  53M 52780 S     0.0  2.6  17:00 oracle
 1023 oracle     9   0 54260  52M 52760 S     0.0  2.6  16:42 oracle
 1031 oracle     9   0 54168  52M 52676 S     0.8  2.6  17:01 oracle
 1025 oracle     9   0 54108  52M 52612 S     0.0  2.6  16:43 oracle
 1027 oracle     9   0 53112  51M 51596 S     0.0  2.5  16:22 oracle
 1039 oracle     9   0 53064  51M 51576 S     0.0  2.5  17:03 oracle
 1035 oracle     9   0 53020  51M 51532 S     0.0  2.5  16:56 oracle
  840 oracle    11   0 45868  44M 40172 S     6.9  2.2  59:19 oracle

SGA Info
SVRMGR> show sga
Total System Global Area                        311500960 bytes
Fixed Size                                          73888 bytes
Variable Size                                   269410304 bytes
Database Buffers                                 40960000 bytes
Redo Buffers                                      1056768 bytes

Comment 2 Michael K. Johnson 2002-03-27 17:36:31 EST
This will be fixed in the next release of Red Hat Linux, as well as
the upcoming Red Hat Linux Advanced Server release.

If you want to test the fix in a non-production environment, you can
use the skipjack beta at
ftp://ftp.redhat.com/pub/redhat/linux/beta/skipjack/en/os/

Note You need to log in before you can comment on or make changes to this bug.