Bug 51245 - add php-curl rpm to php build
Summary: add php-curl rpm to php build
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: php   
(Show other bugs)
Version: roswell
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-08 18:46 UTC by Christopher McCrory
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-07 23:59:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christopher McCrory 2001-08-08 18:46:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010725

Description of problem:

since cURL is included, a php-curl rpm is possible
IIRC, it is also easy

Comment 1 Bert de Bruijn 2001-10-07 01:55:36 UTC
php needs curl now, but it's not on an rpm dependency. 
-> apache+php won't start without curl installed, but the rpm dependencies don't
force you to install it. The errormessage is 
libphp4.so: undefined symbol: curl_global_cleanup

Comment 2 Bill Nottingham 2001-12-08 03:46:11 UTC
This is fixed in the current packages; they have a curl library dependency.


Note You need to log in before you can comment on or make changes to this bug.