Bug 512488 - KDE Daemon crashes afer login on x86_64 and i586
KDE Daemon crashes afer login on x86_64 and i586
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-17 19:15 EDT by Peter Gückel
Modified: 2009-07-31 19:35 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-29 05:49:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Gückel 2009-07-17 19:15:38 EDT
Description of problem:
Log in and wait about 5 minutes. A bing! and a window appear, stating that the KDE Daemon has crashed.

Version-Release number of selected component (if applicable):
4.2.96-1.fc11

How reproducible:
log in, wait 5 minutes

Steps to Reproduce:
1.
2.
3.
  
Actual results:
KDE Daemon crashes, always, after aboout 5 minutes.

Expected results:
It shouldn't crash (don't know what it does)

Additional info:
The system appears to function normally, whether it runs or not. This problem has existed for quite a while, since at least kde 4.2 or so.
Comment 1 Rex Dieter 2009-07-18 18:43:42 EDT
If you could install at least kdelibs-debuginfo , then the backtrace accompanying such crashes may help.
Comment 2 Peter Gückel 2009-07-19 11:07:48 EDT
Application: KDE Daemon (kded4), signal: Aborted
[Current thread is 1 (Thread 0x7fbd27efe820 (LWP 2202))]

Thread 2 (Thread 0x7fbd158f5910 (LWP 2544)):
#0  0x000000397c4d4f73 in poll () from /lib64/libc.so.6
#1  0x0000003923e3b05c in ?? () from /lib64/libglib-2.0.so.0
#2  0x0000003923e3b3a0 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x000000392576840e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x000000392573e5f2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x000000392573e9c4 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x0000003925656f6b in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x0000003925721f08 in ?? () from /usr/lib64/libQtCore.so.4
#8  0x0000003925659cd5 in ?? () from /usr/lib64/libQtCore.so.4
#9  0x000000397d00686a in start_thread () from /lib64/libpthread.so.0
#10 0x000000397c4de25d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fbd27efe820 (LWP 2202)):
[KCrash Handler]
#5  0x000000397c4332f5 in raise () from /lib64/libc.so.6
#6  0x000000397c434b20 in abort () from /lib64/libc.so.6
#7  0x0000003925652194 in qt_message_output(QtMsgType, char const*) () from /usr/lib64/libQtCore.so.4
#8  0x00000039256522e6 in qFatal(char const*, ...) () from /usr/lib64/libQtCore.so.4
#9  0x000000304de17222 in QString PackageKit::Util::enumToString<PackageKit::Client>(int, char const*, QString const&) () from /usr/lib64/libpackagekit-qt.so.11
#10 0x000000304de0cbc5 in PackageKit::Client::getTimeSinceAction(PackageKit::Client::Action) () from /usr/lib64/libpackagekit-qt.so.11
#11 0x00007fbd1f8691a4 in ?? () from /usr/lib64/kde4/kded_kpackagekitd.so
#12 0x00007fbd1f868838 in QMetaObject::changeGuard(QObject**, QObject*) () from /usr/lib64/kde4/kded_kpackagekitd.so
#13 0x0000003925754fdc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQtCore.so.4
#14 0x000000392574ef93 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#15 0x0000003f7138ee2c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#16 0x0000003f71395e5e in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#17 0x0000003f73210456 in KApplication::notify (this=0x7fff3c75b660, receiver=0xe10ca0, event=0x7fff3c75b310) at /usr/src/debug/kdelibs-4.2.96/kdeui/kernel/kapplication.cpp:302
#18 0x000000392573fcbc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#19 0x000000392576aa72 in ?? () from /usr/lib64/libQtCore.so.4
#20 0x000000392576846d in ?? () from /usr/lib64/libQtCore.so.4
#21 0x0000003923e37abe in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#22 0x0000003923e3b278 in ?? () from /lib64/libglib-2.0.so.0
#23 0x0000003923e3b3a0 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#24 0x00000039257683b6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#25 0x0000003f71421b6e in ?? () from /usr/lib64/libQtGui.so.4
#26 0x000000392573e5f2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#27 0x000000392573e9c4 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#28 0x0000003925740b79 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#29 0x0000003f7020b6bb in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdelibs-4.2.96/kded/kded.cpp:938
#30 0x000000397c41ea2d in __libc_start_main () from /lib64/libc.so.6
#31 0x0000000000400709 in _start ()
Comment 3 Lorenzo Villani 2009-07-22 09:26:23 EDT
Do you still experience this problem (even with the latest KDE rc?). Can you also install glib2-debuginfo or 

export QT_NO_GLIB=1

in your ~/.bashrc then logout & login again (this way we shouldn't see calls to the glib library).
Comment 4 Peter Gückel 2009-07-22 14:50:12 EDT
> Do you still experience this problem (even with the latest KDE rc?)?

Yes, of course. I use kde-redhat repo and have 4.2.96-1.fc11.x86_64 installed. This is the latest release candidate.

Instead of installing glib2-debuginfo, I opted for your second suggestion, namely to export the variable. I rebooted and waited for the crash. Here is the output:

Application: KDE Daemon (kded4), signal: Aborted
[KCrash Handler]
#5  0x000000397c4332f5 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#6  0x000000397c434b20 in *__GI_abort () at abort.c:88
#7  0x0000003925652194 in qt_message_output(QtMsgType, char const*) () from /usr/lib64/libQtCore.so.4
#8  0x00000039256522e6 in qFatal(char const*, ...) () from /usr/lib64/libQtCore.so.4
#9  0x000000304de17222 in QString PackageKit::Util::enumToString<PackageKit::Client>(int, char const*, QString const&) () from /usr/lib64/libpackagekit-qt.so.11
#10 0x000000304de0cbc5 in PackageKit::Client::getTimeSinceAction(PackageKit::Client::Action) () from /usr/lib64/libpackagekit-qt.so.11
#11 0x00007f7b771eb1a4 in ?? () from /usr/lib64/kde4/kded_kpackagekitd.so
#12 0x00007f7b771ea838 in QMetaObject::changeGuard(QObject**, QObject*) () from /usr/lib64/kde4/kded_kpackagekitd.so
#13 0x0000003925754fdc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQtCore.so.4
#14 0x000000392574ef93 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#15 0x0000003f7138ee2c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#16 0x0000003f71395e5e in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#17 0x0000003f73210456 in KApplication::notify (this=0x7fff8eafbe70, receiver=0xc01980, event=0x7fff8eafb8e0) at /usr/src/debug/kdelibs-4.2.96/kdeui/kernel/kapplication.cpp:302
#18 0x000000392573fcbc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#19 0x000000392576aa72 in ?? () from /usr/lib64/libQtCore.so.4
#20 0x000000392576b53c in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#21 0x0000003f71422dd7 in ?? () from /usr/lib64/libQtGui.so.4
#22 0x000000392573e5f2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#23 0x000000392573e9c4 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#24 0x0000003925740b79 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#25 0x0000003f7020b6bb in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdelibs-4.2.96/kded/kded.cpp:938
#26 0x000000397c41ea2d in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>,
    rtld_fini=<value optimized out>, stack_end=0x7fff8eafc228) at libc-start.c:220
#27 0x0000000000400709 in _start ()
Warning: the current language does not match this frame.
Comment 5 Peter Gückel 2009-07-22 20:53:32 EDT
What do you know!? I just read, this evening, that a release candidate 3 has just been released. I just checked the repo and it is not there yet. There is a massive rebuild of all Fedora packages starting tomorrow, I think, so I would be surprised if I get this before the weekend.
Comment 6 Kevin Kofler 2009-07-22 21:28:08 EDT
We've imported RC3 into the CVS (or rather, Than Ngo did while the rest of us watched ;-) ), but it'll take a while to build it.
Comment 7 Peter Gückel 2009-07-24 21:34:20 EDT
Wow, those guyz worked fast!

I just upgraded to kde4.3rc3 and yes, the kde daemon still crashes.
Comment 8 Steven M. Parrish 2009-07-25 11:52:33 EDT
Thank you for taking the time to report this issue.

This is an issue that needs to be addressed by the upstream developers. Please report this at http://bugs.kde.org and then add the upstream report information to this report.  We will monitor the upstream report for a resolution to this issue, and will review any bug fixes that become available for consideration in future updates.

Setting status to NEEDINFO, and awaiting upstream bug report URL for tracking.

Thanks in advance.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Lorenzo Villani 2009-07-25 12:22:34 EDT
The bug *seems* to be triggered by kpackagekit kded module. What happens if you just disable KPackageKit? (either by disabling automatic updates and/or uninstalling it)
Comment 10 Peter Gückel 2009-07-25 12:56:53 EDT
I could uninstall kpackagekit and see what happens. I don't use it anyway, as I like to run yum manually on the command line, and kpackagekit never runs anyway - it doesn't seem to do anything, since quite a few months.
Comment 11 Lorenzo Villani 2009-07-25 13:38:04 EDT
Weird, the call stack shows that a function from libpackagekit-qt (used by KPackageKit) is called before kded4 death, my statement above is based on that.

Are you sure that automatic updates checks were disabled too?
Comment 12 Peter Gückel 2009-07-25 13:40:04 EDT
Confirmed!

I uninstalled kpackagekit and have been using the computer, after a reboot, of course, since the last post and the crash has not recurred (it always happened at about 5 minutes from login).

I *hate* all the runaround: now that we have confirmed that it is kpackagekit, do I still have to report upstream?
Comment 13 Peter Gückel 2009-07-25 13:43:15 EDT
(In reply to comment #11)
> Weird, the call stack shows that a function from libpackagekit-qt (used by
> KPackageKit) is called before kded4 death, my statement above is based on that.
> 
> Are you sure that automatic updates checks were disabled too?  

I have no idea how to disable the automatic update checks. I presume that it was still doing them, but since a few months, kpackagekit no longer opens up a window showig what it found. It just never seemed to do anything, except likely the automatic checks that ran in the background, invisible to me.
Comment 14 Rex Dieter 2009-07-25 13:44:49 EDT
Probably best it be you (to report upstream), since (afaict) no one else has been able to reproduce the problem.  But, let's reassign things at least, in the meantime.
Comment 15 Peter Gückel 2009-07-25 13:52:38 EDT
(In reply to comment #14)
> Probably best it be you (to report upstream), since (afaict) no one else has
> been able to reproduce the problem.  But, let's reassign things at least, in
> the meantime.  

I am a bit confused. Ok, I will report upstream, but, as I have uninstalled kpackagekit, which I do not use, how can I reproduce the problem for them upstream?

Also, you say, "let's reassign things"... so what does that mean? Should I wait for further word from here, or what are you telling me?
Comment 16 Rex Dieter 2009-07-25 15:22:20 EDT
reassign to kpackagekit (instead of kdebase), but it seems my change didn't take.  doing so now.

That said, if no one else can or will reproduce this, the likelyhood of it getting fixed is much less.
Comment 17 Steven M. Parrish 2009-07-25 19:17:24 EDT
can you do 

rpm -q kpackagekit PackageKit

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 18 Peter Gückel 2009-07-25 20:19:51 EDT
rpm -q kpackagekit PackageKit:

package kpackagekit is not installed
PackageKit-0.4.8-2.fc11.x86_64
Comment 19 Peter Gückel 2009-07-25 20:21:29 EDT
The KDE bug is:

bugs.kde.org/show_bug.cgi?id=201503
Comment 20 Peter Gückel 2009-07-28 13:48:02 EDT
It is now fixed.

You have to uninstall and then reinstall kpackagekit to get it to work.

If I understand correctly, the problem is that the developer didn't increase the version number, so yum couldn't upgrade to the fixed version.
Comment 21 Lorenzo Villani 2009-07-29 05:49:43 EDT
Great, but I think we (KDE SIG) should put notes somewhere..
Comment 22 Steven M. Parrish 2009-07-31 19:35:17 EDT
Actually there has been no new release of kpackagekit recently so what you reinstalled was the same thing you had before.  What has changed in Packagekit which is where the packagekit-qt libs live.  

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.