Bug 51254 - 4.0.2 --relocate broken
4.0.2 --relocate broken
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-08 15:40 EDT by Rob Landry
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-08 16:03:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Landry 2001-08-08 15:40:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.6-3.1 i686)

Description of problem:
I think I would like to get a 4.0.2 version of rpm.
It doesn't have to be official, just needs to have
the --relocate fix in it.  I am nervous about using
the 4.0.3 version since it is the "development" version.
Just an FYI, in 4.0.2 (6x) --relocate was broken; in
4.0.3-0.6.6x you couldn't update a db1 to a db3 with
--rebuilddb and in 4.0.3-0.57.6x you get lots of warnings
about creating directories with 0755 permissions.


How reproducible:
Always

Steps to Reproduce:
1.install the updated version of rpm for 6.2
2.
3.
	

Additional info:

Original message sent to me:

We
> > have incorporated all of the 6.2 security patches into
> > our system.  However,  rpm-4.0.2-6x (the security update
> > for rpm) does not work with the --relocate flag which
> > we need to install our EMC rpm (bugzilla #42873).  This
> > is fixed in rpm-4.0.3 but I can't install this on a
> > 6.2 system without breaking a number of other dependencies
> > (glibc, etc....).  Do you know if there is a 4.0.2 version
> > with the fix?
Comment 1 Jeff Johnson 2001-08-08 16:11:34 EDT
If you truly want a version of rpm-4.0.2 with working
--relocate, then tyou need to build your own with the
patch from rpm-4.0.3-0.6. There are two routines in
lib/transaction.c that need fixes, not hard.

Before doing that, I suggest that current rpm-4.0.3 (-0.89
is building now), is a better choice, as the 'development"
in rpm-4.0.3 stopped like 2 months ago, since then has
been largely (and sometimes large ) bug fixes. At this
point, rpm-4.0.3 is the best bits I got.

Yes rpm-4.0.3 is know to upgrad db1 -> db3. 
The messages about creating directories are harmless,
the directories have always been created, rpm-4.0.3
]now just warns you.
Comment 2 David Lawrence 2001-08-14 12:56:45 EDT
Removed all permission from this bug so everyone can see it.

Note You need to log in before you can comment on or make changes to this bug.