Bug 512633 - KVM virtio network drops out, shutdowns VM and causes blue screen with WinXP VM
KVM virtio network drops out, shutdowns VM and causes blue screen with WinXP VM
Status: CLOSED DUPLICATE of bug 512289
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-19 23:07 EDT by Paul Lambert
Modified: 2009-07-21 14:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-20 09:48:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manger.log, blue screens, WinXP minidmp files (479.49 KB, application/zip)
2009-07-19 23:07 EDT, Paul Lambert
no flags Details

  None (edit)
Description Paul Lambert 2009-07-19 23:07:19 EDT
Created attachment 354297 [details]
virt-manger.log, blue screens, WinXP minidmp files

Description of problem:Using virtio network driver on Windows-XP-SP3 network will: 1) stop functioning until being reset, 2) instantly shutdown the VM or 3) crash the WinXP OS giving a blue screen with either a IRQL or file error.


Version-Release number of selected component (if applicable): 2.6.29.5-191.fc11.i586


How reproducible:  Consistent after a period of network surfing or downloading Email


Steps to Reproduce:
1.Launch WinXP VM
2.Open FF in WinXP start surfing
3.
  
Actual results:
Network times out

Expected results:


Additional info:

I have completed these steps believing there was a link to other drivers.

1) removed USB devices from WinXP VM
2) removed sound device from WinXP VM

After (1) the freqeuncy was reduced and I only experienced IRQL errors
After (2) the freqeuncy was reduced further but did experience a complete VM shutdown and IRQL errors.  

FF running on the guest WinXP will eventually give network timeout errors.  FF on the host (Fedora) still works OK.
Comment 1 Glauber Costa 2009-07-20 09:48:08 EDT
This is probably duplicate of 512289. There is a kernel update for that.
If this is in fact a duplicate, you should be able to get it fixed by downloading a newer kernel from koji. (at least 2.6.29.6-213)

I'm marking as duplicate. Please re-open if it is not.

*** This bug has been marked as a duplicate of bug 512289 ***
Comment 2 Paul Lambert 2009-07-20 21:15:12 EDT
This bug needs to re-opened as the 2.6.29.6.213.fc11,.i586 kernel is actually crashing more frequently and sooner than the previous version.  This root cause of this bug is not the same as that of bug#512289.

After installing Fedora kernel 2.6.29.6-213.fc11.i586 open T-Bird Email, downloaded, then launched FF and starting surfing web.  Less that 5 minutes later experience WinXP blue screen due to IRQL error.  Forced shtudown of VM and restarted.  Launched just FF and crashed with same error in less than one minute.
Comment 3 Paul Lambert 2009-07-20 22:23:44 EDT
This condition is explained by MS at this website for physical hardware.
http://support.microsoft.com/default.aspx?scid=kb;en-us;314063
Comment 4 Paul Lambert 2009-07-21 14:46:40 EDT
I have removed the virtio network driver and reverted back to the Realtek RTL8139 hardware driver.  Have not experienced any WinXP crashes even while two USB devices connected concurrently.  This is a virtio driver issue.  Maybe there is a newer version, I installed the version listed below.  Please advise is there is a newer version available.

ClassGUID   = {4d36e972-e325-11ce-bfc1-08002be10318}
Provider    = %Qumranet%
DriverVer   = 05/12/2008,1.2.0.0

Note You need to log in before you can comment on or make changes to this bug.