This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 512712 - Support huge pages in KVM
Support huge pages in KVM
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Marcelo Tosatti
Lawrence Lim
: TechPreview
: 513314 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-20 10:00 EDT by Andrew Cathrow
Modified: 2014-09-07 18:52 EDT (History)
11 users (show)

See Also:
Fixed In Version: kvm-83-97.el5
Doc Type: Technology Preview
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:29:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 1 Dor Laor 2009-07-20 10:16:20 EDT
Marcelo, note that the migration fixes are not needed. Just any other fixes.
Comment 5 Marcelo Tosatti 2009-07-20 12:42:48 EDT
There are no major fixes (other than the migration one), which would prevent preview of hugetlbfs backed guests.

Of course some basic testing by QA would be nice.
Comment 6 Dor Laor 2009-07-20 15:08:54 EDT
In that case, it's much more simple. Marcelo, can you please post the dirty page tracking and we'll call it a day.
Since the performance group did stress test it quite well.
Comment 10 Eduardo Habkost 2009-07-23 10:37:55 EDT
*** Bug 513314 has been marked as a duplicate of this bug. ***
Comment 17 lihuang 2009-08-14 20:33:12 EDT
(In reply to comment #5)
> There are no major fixes (other than the migration one), which would prevent
> preview of hugetlbfs backed guests.
> 
> Of course some basic testing by QA would be nice.  

run RHEL4u8 32/64,RHEL5u4 32/64,window2k3 32,window 2k8 32 
and run stress inside the linux guests,sp2004 inside window guests 
both guest and host are healthy during the testing 


(In reply to comment #10)
> *** Bug 513314 has been marked as a duplicate of this bug. ***  
Can not Reproduce the issue in kvm-83-105.el5.

setting to *VERIFIED*
Comment 18 Dor Laor 2009-08-16 02:19:46 EDT
Please make sure migration of a guest with large pages backed memory works.
This was the latest fix.
Comment 20 errata-xmlrpc 2009-09-02 05:29:49 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1272.html

Note You need to log in before you can comment on or make changes to this bug.