Bug 512733 - SSSD: Services are dead but pid file exists
SSSD: Services are dead but pid file exists
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
11
All Linux
high Severity medium
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
:
: 512731 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-20 11:45 EDT by Jenny Galipeau
Modified: 2010-01-12 08:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-12 08:32:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jenny Galipeau 2009-07-20 11:45:58 EDT
Description of problem:

If you try to start SSSD services with an invalid sssd.conf file - example: no
domains configured.  The service appears to start successfully and returns 0.


[root@localhost sssd]# service sssd start
Starting sssd:                                             [  OK  ]

[root@localhost sssd]# echo $?
0

[root@localhost sssd]# service sssd status
sssd dead but pid file exists

[root@localhost sssd]# ps -ef | grep sssd
root     11646 11544  0 11:36 pts/0    00:00:00 grep sssd

This is true for both Fedora 11 and RHEL 5.3.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.  yum install sssd
2.  do not edit sssd.conf file, but use default with no domains configured and
start SSSD
    service sssd start
3.  echo $?
4.  service sssd status
5.  ps -ef | grep sssd

Actual results:
Service appears to start successfully
return code status is 0
pid file is created even though service did not start

Expected results:
Appropriate error message 
non 0 return code status
pid file not created


Additional info:  

bug also filed with freeIPA for verification on RHEL
Comment 1 Jenny Galipeau 2009-07-20 11:46:50 EDT
freeIPA bug is 512731
Comment 2 Jenny Galipeau 2009-07-30 11:55:57 EDT
*** Bug 512731 has been marked as a duplicate of this bug. ***
Comment 3 Stephen Gallagher 2010-01-12 08:32:11 EST
Fixed in sssd-1.0.1-1.fc11
Comment 4 Jenny Galipeau 2010-01-12 08:45:40 EST
Fix has been verified and is regression tested with daily automated acceptance.

Note You need to log in before you can comment on or make changes to this bug.