Bug 51278 - Invalid status from mii-tool
Summary: Invalid status from mii-tool
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: net-tools   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-08 23:20 UTC by Mark H Johnson
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-08 23:20:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark H Johnson 2001-08-08 23:20:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.6-3.1smp i686)
[yes - its really Roswell, I couldn't select it from the version list]

Description of problem:
Network card failed to use DHCP to set up address due to incorrect status
returned by mii-tool.

How reproducible:
Always

Steps to Reproduce:
1. Change from manual IP addresses to DHCP on eth0
2. /etc/rc.d/rc5.d/S10network restart

	

Actual Results:  Error message indicates "no link", then [FAILED].

Actual output from mii-tool was...
eth0: 10 Mbit, half duplex, no link


Expected Results:  Expected [OK] from start up script, no diagnostic
messages.

Actual output from mii-tool should indicate 100 Mbit, link active, ....

Additional info:

cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE="eth0"
BOOTPROTO="dhcp"
ONBOOT="yes"
IPADDR="192.27.48.41"
NETMASK="255.255.255.128"

cat /etc/modules.conf
alias eth0 8139too
alias parport_lowlevel parport_pc
alias sound-slot-0 es1371
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null
2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null
2>&1 || :
alias usb-controller usb-uhci

Comment 1 Bill Nottingham 2001-08-09 06:17:51 UTC
This is fixed in that the initscripts don't use mii-tool anymore as of 6.11-1;
it is not reliable enough.


Note You need to log in before you can comment on or make changes to this bug.