Bug 51300 - mozilla nautilus component will crash when trying to submit a form
mozilla nautilus component will crash when trying to submit a form
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: mozilla (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
http://www.google.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-09 03:34 EDT by Christopher Blizzard
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-09 16:10:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (5.25 KB, patch)
2001-08-09 03:46 EDT, Christopher Blizzard
no flags Details | Diff
mozilla patch (730 bytes, patch)
2001-08-09 03:49 EDT, Christopher Blizzard
no flags Details | Diff
patch (6.01 KB, patch)
2001-08-09 14:50 EDT, Christopher Blizzard
no flags Details | Diff
patch after alex's kind comments (5.76 KB, patch)
2001-08-09 15:31 EDT, Christopher Blizzard
no flags Details | Diff

  None (edit)
Description Christopher Blizzard 2001-08-09 03:34:10 EDT
Description of Problem:

When trying to submit a search form at google's search engine the nautilus
component will crash.

How Reproducible:

Every time.

Steps to Reproduce:
1. Go to http://www.google.com
2. Type something in to search
3. Click the search button

Actual Results:

The component crashes.

Expected Results:

The search will work.

Additional Information:

Even with the fix for this installed nautilus will still barf on the form
because of the warning that mozilla wants to produce.  I'll attach a
seperate patch for that issue.
Comment 1 Christopher Blizzard 2001-08-09 03:46:44 EDT
Created attachment 26973 [details]
patch
Comment 2 Christopher Blizzard 2001-08-09 03:49:47 EDT
Created attachment 26974 [details]
mozilla patch
Comment 3 Christopher Blizzard 2001-08-09 03:53:46 EDT
There are two patches here.  The first is for Mozilla.  It's being included in
the 0.9.2-10 rpm which I'm trying to spin.

The second is for Nautilus.  It adds the ability to create windows off of the
mozilla view for special Mozilla chrome windows.  These chrome windows include
alerts on web pages, a dialog that might ask you for your http password or the
warning about the form that you are about to submit being insecure.

Without this patch you can't submit the form on google's site because there's a
warning dialog that's supposed to pop up to warn you about submitting insecure
data.  Nautilus doesn't support opening a chrome window so you can never click
OK on the dialog so you are never able to submit forms.  How's that for fun?
Comment 4 Christopher Blizzard 2001-08-09 03:58:35 EDT
Crap.  It just occurred to me that I forgot to add the ability to close down the
new widgets in question if the view was destroyed which was the whole reason
that I added the list of windows.  I'll fix that up in the morning.  It's late.
Comment 5 Christopher Blizzard 2001-08-09 14:50:18 EDT
Created attachment 27114 [details]
patch
Comment 6 Christopher Blizzard 2001-08-09 15:31:10 EDT
Created attachment 27133 [details]
patch after alex's kind comments
Comment 7 Glen Foster 2001-08-09 16:10:08 EDT
We (Red Hat) should really try to fix this before next release.
Comment 8 Christopher Blizzard 2002-01-25 15:48:57 EST
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.